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前  言 

很多朋友都想自己动手开发 ARM应用程序，却不知从哪儿下手。我们编写本手册的目的就是想帮助这

些初学者轻松的入门。 

应该说，入门学会开发 ST ARM应用程序并不难，但要全面掌握和融会贯通则需要付出许多努力。因

为本手册的目的只是帮助新手入门，所以我们在编写时大胆地砍去许多旁支侧节，避免过多介绍细节，紧

紧地抓住如何使用 ARM开发工具和使用芯片商提供的软件库为主线，单刀直入，使读者无须阅读许多资料，

短时间就能掌握开发 ARM应用程序的基本技巧。 

本手册以 IAR 公司的 EWARM 开发环境和 ST 公司的 STR710-EVAL 评估板为基础，介绍如何编写

STR710（ARM7 内核）的 C 语言应用程序。手册的前半部分介绍 IAR Systems 公司的 ARM 开发环境

EWARM的使用方法，后半部分介绍如何利用 ST公司提供的 STR710软件库和例子编写自己的应用程序。

用户只需按照本手册介绍的步骤，一步一步去做，相信只需几天的时间就能初步掌握使用 IAR EWARM开

发环境和编写 ST ARM的应用程序的基本技巧。 

相对 51 单片机，ARM 的结构和应用确实要复杂的多。要真正熟练使用 ARM 处理器需要学习许多相

关知识。希望学习 ARM的朋友在初步入门后，继续学习本手册中提到的相关资料，通过不断的学习和实践

扩充知识和提高自己的水平。 

实践 ARM开发需要准备以下软硬件： 

1. IAR的 JTAG仿真器 J-Link                            （从万利公司购买） 

2. IAR Embedded Workbench for ARM version 4.31        （从 IAR网站下载） 

3. ST公司的 ATR710-EVAL评估板                       （从万利公司购买） 

4. ST 公司的 ATR710-EVAL评估板源程序包 01STR71x     （从万利网站下载） 

 

需要获得更多知识请参阅以下资料： 

1． ARM Embeded Workbench User Guide        （在 EWARM主菜单的 Help下） 

2． ARM C/C++ Compiler Reference Guide        （在 EWARM主菜单的 Help下） 

3． ARM_Assembler Reference Guide            （在 EWARM主菜单的 Help下） 

4． Linker and Library Tools Reference Guide      （在 EWARM主菜单的 Help下） 

5． STR71xF用户手册                           （从万利网站下载）                   

6． STR71xF教程（PPT）                       （从万利网站下载） 
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第一章 EWARM集成开发环境及 J-Link仿真器 
1．IAR EWARM 简介 

IAR Embedded Workbench for ARM（下面简称 IAR EWARM）是一个针对 ARM处理器的集成开发

环境，它包含项目管理器、编辑器、C/C++编译器和 ARM汇编器、连接器 XLINK和支持 RTOS的调试工

具 C-SPY。在 EWARM环境下可以使用 C/C++和汇编语言方便地开发嵌入式应用程序。比较其他的 ARM

开发环境，IAR EWARM具有入门容易、使用方便和代码紧凑等特点。有关 EWARM详细特点介绍请参考

万利公司编写的《IAR EWARM快速用户指南》。 

IAR EWARM的最新版本是 4.31。为了方便用户学习评估，IAR提供一个限制 32k代码的免费版本。

用户可以到 IAR公司的网站 www.iar.com/ewarm 或万利电子的网站 www.manley.com.cn (本地网站)去寻

找和下载。 

IAR EWARM中包含一个全软件的模拟程序（simulator）。使用它不需要任何硬件支持就可以模拟各

种 ARM内核、外部设备甚至中断的软件运行环境，从中可以了解和评估 IAR EWARM的功能和使用方法。

有关 EWARM模拟程序的用法请参考万利公司编写的《IAR EWARM快速用户指南》。但本手册着重介绍

针对 ST公司的 STR710评估板真实硬件的开发流程。 

 

2．IAR J-Link 仿真器简介 

IAR J-Link是 IAR为支持仿真 ARM内核芯片推出的 JTAG方式仿真器。结合 IAR EWARM集成开发环

境可支持所有 ARM7/ARM9内核芯片的仿真。 

J-Link ARM 主要特点如下： 

 支持所有 ARM7/ARM9内核的芯片，包括 Thumb模式 

 下载速度高达 600 kB/s 

 最高 JTAG速度 12 MHz 

 目标板电压范围 1.2V – 3.3V 

 自动速度识别功能 

 自动监测所有 JTAG信号和目标板电压 

 J-Link本身使用 PC机给 USB端口的电源 

J-LINK一端通过 USB口与 PC连接，另一端通过标准 20芯 JTAG插头与目标板连接。连接时应首先

将 J-LINK与 PC连接,再将 J-LINK与目标系统连接，最后给目标系统供电（如果目标系统为独立供电、而

非由 J-TAG口供电的情况）。 

注意： 

当目标系统为 5V电源系统时，必须使用 J-LINK提供的 5V电源适配器选件。对于 1.2V~3.3V电源系

统，可以直接使用 J-Link。使用时将适配器的 20芯 IDC插头插进 J-Link的 20芯插座，再将连接目标板的

20芯扁平电缆插进适配器的插座。5V适配器选件由目标供电(3.3V~ 5V)，电流<20mA，有一个 LED指示

电源状态。 
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图 1-1. 带 5V适配器的 J-Link 

 

3．安装 EWARM 

用户可以从万利电子有限公司的网站主页 www.manley.com.cn下载 EWARM 4.31A(32K)版本的软件

(包含 J-LINK驱动程序)及许可证。 

 

图1-2. 万利公司主页 

 

安装EWARM 4.30A软件方法如下： 

① 将安装程序包解压 

 
② 选择并运行文件 autorun.exe 

 
③ 点击 Install the IAR Embedded Workbench，开始安装。见图 1-3。 
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图 1-3. 安装 EWARM 

 

④ 输入许可证号（License）和密钥（License key） 

     用户从下载的软件包中的文本文件中提取许可证号（License）和密钥（License key），分别输入下

面两个窗口（见图 1-4和图 1-5）。许可接受后建议按默认设置安装。 

 

 

图 1-4. License输入窗口 

 

 

图 1-5. License key输入窗口 
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⑤ 安装完成后添加 J-LINK驱动程序 

退回安装主界面，点击 Install drivers后弹出图 1-6的目录。选择其中的 JLink目录，将其整个复制
到另一个文件夹中（用户可以新建一个文件夹）。 
 

 

图 1-6. 安装 J-Link驱动程序 

 

用 USB电缆将 J-LINK仿真器与 PC机连接，这时会弹出图 1-7所示硬件安装向导窗口 

 

 
图 1-7. 硬件安装向导窗口 

 

选择从列表或指定位置安装，指向先前新建文件夹中的 JLink目录，如图 1-8所示。 

 
图 1-8. 指向 JLink目录 
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安装完成后启动 EWARM环境，如图 1-9所示。 
 

 
 
 
将 J-Link 的 20 芯电缆与 STR710-EVAL评估板的 JTAG 插座相连。接通评估板电源，按第二章中步
骤执行后面的操作。 
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第二章 在 EWARM中生成一个新项目 
要为某个目标系统开发一个新应用程序，必须建立一个新项目。步骤如下： 

1．建立一个项目文件目录 

首先应该为新项目创建一个目录，用来存放与项目有关的各种文件。项目开发过程中生成的一系列文

件，如：工作区文件，开发环境的配置，编译、连接和调试选件配置，各种列表文件和输出文件等都将被

存放在这个目录下。用户也可以选择把各种原文件也放在这个目录下。在下面的例子中我们生成一个

C:\Program files\IAR System\My projects目录。为了方便，我们把 ST的例子软件包 01STR71x也复制到

此目录下。 

 

2．生成新的工作区 
EWARM虽然是按项目进行管理，但是要求把所有的项目都放在工作区内（Workspace）。用户如果

是第一次使用 EWARM开发一个新项目，必须先创建一个新工作区，然后才能在工作区中创建新项目。一

个工作区中允许存放一个或多个项目。如果用户过去已经建立了一个工作区并且希望把目前要建的新项目

放在老工作区内，则可以直接打开老工作区并执行第三步生成新项目。 

创建新工作区方法是：选择 EWARM开发环境主菜单的 File > New > Workspace命令。如果目前正

在开发或调试另一个项目，EWARM 开发环境将提示用户保存和关闭当前活跃工作区，然后开启一个空白

工作区窗口，如图 2-1所示。 

 

 

                                   图2-1. 创建新工作区    

 

注意：第一次使用 EWARM开发环境时也显示上述空白工作区窗口。 

   

3．生成新项目 

    下一步就是在工作区中创建新项目，方法如下： 
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① 选择主菜单 Project > Create New Project，弹出生成新项目窗口，见图 2-2。EWARM提供几种应

用程序和库程序的项目模板。如果选择 Empty project，表示采用默认的项目选件设置。在本例中我们选择

Empty project。 

    

 

图 2-2. 生成新项目窗口 

 

② 在 Tool chain栏中选择 ARM，然后点击 OK按钮，弹出 “另存为”窗口。 

③ 在“另存为”窗口中浏览和选择新建的 My projects 目录，输入新项目的文件名为 STR710-LED，

然后保存。这时在屏幕左边的Workspace窗口中将显示新建的项目名和输出代码模式。见图 2-3所示： 

 

 
                                   图 2-3.  生成新项目 

                        

项目名后面的 Debug 表示输出含调试信息的代码文件。EWARM 能为项目提供两种输出代码模式：

Debug和 Release。Debug模式生成含调试信息的程序代码，用户利用它可以在 EWARM环境下调试应用

程序。而 Release模式生成不含调试信息的发行版本的程序代码，其代码比较紧凑。用户可以从Workspace



 
EWARM应用入门指南 万利电子有限公司 整理 

地址：南京市新模范马路17号02幢2层 电话：025-83235502 / 83235503 
邮编：210003 传真：025-83235501 

10

窗口顶部的下拉菜单中选择两种项目配置之一，本例我们选择 Debug。 

现在 My projects目录下已生成一个 STR710-LED.ewp文件，该文件中将包含与 STR710-LED项目设

置有关的信息，如编译、连接（build）的选件等。 

注意：STR710-LED-Debug后的﹡号表示当前的工作区和项目经修改后还没有被保存。 

④ 保存工作区 

新生成的工作区需保存才有效，所以在添加项目后 EWARM要求执行保存工作区操作。保存工作区选

择主菜单 File > Save Workspace，浏览并选择 My projects目录。然将工作区取名为 ST710-DEMO输进

File name输入框，按保存按钮退出。这时在 My projects目录下又生成一个 ST710-DEMO.eww文件。同

时在 My projects目录下还生成一个 settings子目录，这个目录下存放保存窗口设置和断点设置等与当前操

作有关信息的其他文件。 

注意：保存操作完成后项目名后的﹡号已经消失。 

 

4. 给项目添加文件 

保存工作区后的下一步就是往项目中添加文件。项目中的文件允许分组，用户可以根据项目的需要和自

己的习惯来组织源文件。为举例说明，我们在下面的例子中建立一个 startup文件组。 

注意：往项目中添加文件时只需添加汇编语言和 C 语言的源程序，不需要添加头文件。但是用户必须

在配置项目的编译器、连接器选件时指明包含头文件的路径和目录。关于项目配置选件的设定我们会在后

面详细介绍。 

新建项目 STR710-LED是一个循环点亮 ATR710-EVAL评估板上的 4个 LED（LED11- LED14）的简

单例子。我们用它来介绍 STR710 应用程序的开发流程。这个应用例子所需的所有源程序都在

STR710-EVAL目录下。其中有两个 c源程序：71x_it.c和 main.c。另有两个 ARM汇编语言程序：71x_init.s

和 71x_vect.s。后两个属启动程序，放在 01str71x\STR710-EVAL\startup目录下。 

添加文件的操作方法如下： 

① 选择工作区窗口中的 ST710-LED–Debug 名，使其高亮。按鼠标右键在弹出菜单中选择 Add 

Group…或选择主菜单 Project > Add Group…执行添加文件组命令。在弹出菜单中将文件组也起名为

startup。 

② 在工作区窗口中选择刚建立的文件组目录 startup，使其高亮。然后按鼠标右键在弹出菜单中选择

Add Files…或选择主菜单  Project > Add Files…执行添加文件命令。 在弹出添加文件窗口中浏览

01str71x\STR710-EVAL\startup 目录，从中选择 71x_init.s 和 71x_vect.s。这两个文件将被添加到工作区

窗口的 startup目录下。 

③ 重新选择工作区窗口中的 ST710-LED – Debug名，按鼠标右键在弹出菜单中选择 Add Files…或选

择主菜单 Project > Add Files…执行添加文件命令。在弹出添加文件窗口中浏览 01str71x \STR710-EVAL

目录，从中选择 71x_it.c和 main.c。 

    现在的工作区窗口中的显示如图 2-4所示。 
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                                图 2-4. 添加文件后的工作区窗口 

 

5. 设置项目选件 

生成新项目和添加文件后的下一步是为项目设置选件。设置项目选件是非常重要的一步，如果设置不

当，编译、连接就会出错，就无法生成正确的代码文件。大家记得，在创建新项目时我们选择了 Empty project

模板，表示采用默认的项目选件设置。但是这些默认的设置还要根据具体项目的需要进行修改。 

IAR EWARM提供的项目选件内容繁多，初学者可能会感到不摸头脑、无从下手。实际上最关键的选

件并不多，只要把它们设置正确了，其它的采用默认设置就不会出错。下面我们把这些关键选件设置逐条

介绍： 

① 通用选件设置 

IAR EWARM允许为工作区中的任何一级目录和文件单独设置选件，但是用户必须首先为整个项目设

置通用的选件 General Option。 

设置方法是：选中工作区中的项目名 STR710-LED – Debug，按鼠标右键在弹出菜单中选择 Options…

或选择主菜单 Project > Options…。在弹出的 Options窗口左边的目录（Category）中选择第一项 General 

Options。然后分别在： 

 Target 页面中，Processor Variant 框中选择 Device。并点击右边的器件选择按钮选择芯片型号

ST STR710。同时 Processor mode选择 ARM，Endian mode选择 Little，Stack align选择 4 byte。

如图 2-5所示； 

注意：Empty project模板默认的处理器模式是 Thumb，即生成 16位指令代码。但是在 STR710-LED

项目中，软件要求生成 32指令代码（CODE32），所以应改选 ARM。 

 Output页面中，Output file框下选择 Executable； 

 Library Configuration页面中，Library条目下选择 Normal。 

 Library Option页面中采用默认选择 
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                            图 2-5.  General Option 选件设置 

 

② C/C++编译器选件设置 

在 Options窗口的目录 Category中选择第二项 C/C++ Compiler。C/C++编译器的选件设置如下： 

 Language页面中，分别在三个选择框中选择 C，Allow IAR extensions，unsigned； 

 Optimization页面中，根据项目需要选择按 size优化还是按 speed优化，再选择优化等级。本例

选择 Size，Low； 

 Output页面中，选择 Generate debug information； 

 List页面中，选择 Output list file，并选择 Assemble mnemonics和 Diagnostics； 

 Preprocessor页面中，列有标准的 include文件的目录。如果用户的 include文件不在标准目录下

时，必须在 Additional include directories输入包含该项目 include文件的目录。一个目录用一行

描述，有多个目录时允许用多行。在本例中，我们选择 01str71x\STR710-EVAL\include，见图 2-6。 
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图 2-6. C/C++ 选件窗口 

 

③ Assembler 选件设置 

在 Options窗口的目录 Category中选择第三项 Assembler。汇编器的选件设置如下： 

 Language页面中，选择 User symbols are sensitive，并选择合适的宏汇编括号（Macro quote 

character）。本例选用<>； 

 Output页面中，选择 Generate debug information； 

 List页面中，选择 Output list file，并根据需要选择各子项； 

 Preprocessor 页面中，列有标准的 include 文件的目录。如果用户的 include 文件不在标准目录

下时，必须在 Additional include directories输入包含该项目 include文件的目录。一个目录用一

行描述，有多个目录时允许用多行。 

 Diagnostic页面中，选择 Enable和 All warning。 

 

④ Linker 选件设置 

在 Options窗口的目录 Category中选择第六项 Linker。连接器的选件中最重要的设置是以下几个： 

 Output 页面，选择合适的输出格式十分重要。如果需要将输出文件送给一个调试器进行调试，

则要求输出格式带有调试信息。本例选择 Debug information for C-SPY。以及此选项下的选件

With runtime control modules，With I/O emulation modules和Allow C-SPY-specific extra output 

file。见图 2-7。 

注意：I/O emulation modules指示连接器将 stdin和 stdout指向 C-SPY的 I/O窗口的低级例程。

在没有真实硬件采用模拟仿真时应选择此项选件。 

 Extra Output页面选择 Generate extra output file。输出格式选择 simple-code和 None； 
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 Diagnostics页面选择 Generate errors； 

 List页面，选择 Generate linker listing和 Segment map（见图 2-8），允许生成存储器分配 MAP

文件。 

 

图 2-7. 连接器 Output 选件设置 

 

 

图 2-8. 连接器 List 选件设置 

 

 Config页面，主要是定义连接器命令文件（Linker Command File）。这是连接器选件中最重要

同时也是最复杂的设置。连接器命令文件中包含连接器的各项命令行参数，主要用于控制程序各

种代码段和数据段在存储器中如何分布。用户一定要吃透和掌握如何生成正确的连接器命令文

件。为了帮助初学者理解，我们增加了下面一段介绍： 
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附注：段的存储器分配方法 

用户在开发以 ARM7或 ARM9为内核的嵌入式应用系统时会采用不同半导体厂家的产品，每种芯片内

部 SRAM和 FLASH的大小和地址分布都不同，另外用户目标系统配置的外部存储器也不同，用户应用软

件要求的存储器分配也不相同。以上所有的不同最后落实到在运行时不同的代码段和数据段的存储器地址

分配方案。而这种运行时存储器分配必需在连接器命令文件中说明，并由连接器 IAR XLINK生成。 

经 XLINK连接生成的代码文件下载到目标板时的地址，由 FlashLoader执行，后面将介绍。 

IAR EWAR 提供默认的连接器命令文件，它在 IAR EWAR 安装目录的 ARM\config 目录下，名字叫

lnkarm.xcl。但是默认的连接器命令文件 lnkarm.xcl不能完全适用特定的目标系统，必须加以修改。下面介

绍几个连接器命令选件的功能和用法： 

命令

选件 

功  能 举      例  

-DROMSTART=0x40000000         

-DROMEND=0x4003FFFF    

说明STR710内部Flash的地址分布说明存储器块

的起始地址和

结束地址 -DROMSTART=0x2000000         

-DROMEND=0x2000FFFF   

说明 STR710内部 RAM的地址分布

 

 

-D 

说明段（堆栈）

的空间大小 

-D_CSTACK_SIZE=100 CSTACK是在启动程序 71x_init.s中

定义的段，此命令给它分配 100字节

按段出现的顺

序进行段定位 

-Z(CODE)ICODE=0x40000000-0x4003FFFF 

-Z(CODE)CODE_ID= 0x40000000-0x4003FFFF 

把代码段 ICODE和 CODE_ID顺序

放置在 STR710 内部 Flash 地址

0x4000000 - 0x4003FFFF内。 

 

 

 

-Z 按段出现的顺

序进行段定位，

同时分配空间 

-Z(DATA)CSTACK+2000=20000000-2000FFFF 

-Z(DATA)IRQ_STACK+100=20000000-2000FFFF 

分配堆栈 CSTACK  2000个字节，

分配)IRQ_STACK 100个字节，顺序

放置在 STR710 内部 RAM 地址

0x20000000 - 0x2000FFFF内。 

-P 把离散的存储

器空间分配给

段 

-P(DATA)MYDATA=10000-101FFF，110000-111FFF 用-P命令后，就不能用汇编命令SFB

和 SFE 获得该段的起始地址和结束

地址。 

-carm 采用的 CPU -carm  

表 2-1.  主要的连接命令选件 

 

用户可以使用上述命令选件进行段的存储器地址分配。 

在连接器命令文件中需要对两种段进行说明。一是 IAR C/C++编译器定义的段名，二是启动程序（汇

编语言程序）中定义的堆栈。下面分别叙述： 

ⅰ）IAR C/C++编译器定义了许多不同用途的段名，其种类繁多，简单介绍请见表 2-2。用户应该查阅

《EWARM C Compiler.pdf》中的 Segment reference章节详细了解。在默认的 lnkarm.xcl文件中，几乎对

所有 C/C++编译器定义的段都已经有默认的说明，用户不必去修改。但是需要在默认的 lnkarm.xcl 文件的

头部（ -carm命令选件的前面）增加以下语句： 
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-DROMSTART=0x????????    

 -DROMEND=0x????????      

-DRAMSTART=0x????????    

 -DRAMEND=0x????????     

     -DVECSTART=ROMSTART  

以上语句是定义片内 ROM和 RAM的地址范围，数值???????用 16进制表示。XLINK对所有段的地

址分配都被限定在前 4 句定义的范围内。第 5 句指定 INTVEC 段的起始地址在 ROM 起始地址，INTVEC

用于保存复位和异常向量。用户应注意 INTVEC段必须放在 ROM（当指定程序在 ROM中运行时）或 RAM

（当指定程序在 RAM中运行时）的起始地址 0-3F处。 

因为在 STR710-LED项目中， INTVEC至少需要 428个字节，低于此数值连接处理将出错。所以 

将 lnkarm.xcl文件中原来的-Z(CODE)INTVEC=0-3F修改成： 

-Z(CODE)INTVEC=VECSTART:+0x428 

ⅱ）启动程序（71x_init.s）中定义的所有堆栈和堆（Heap）必须在连接器命令文件中加以说明，缺一不可，

否则就会报错。根据 STR710-LED项目启动程序选择以下命令： 

-Z(DATA)CSTACK+2000=RAMSTART-RAMEND 

-Z(DATA)IRQ_STACK+100=RAMSTART-RAMEND 

-Z(DATA)FIQ_STACK+100=RAMSTART-RAMEND 

-Z(DATA)SVC_STACK+100=RAMSTART-RAMEND 

-Z(DATA)ABT_STACK+100=RAMSTART-RAMEND 

-Z(DATA)UND_STACK+100=RAMSTART-RAMEND 

-Z(DATA)HEAP+8000=RAMSTART-RAMEND 

以上命令为各堆栈和堆分配存储空间，同时把它们顺序地放置在片内 RAM空间内。用户可以根据应用

的需要为堆栈分配空间。经过上述修改后，保存文件，并在 Linker选件 config页面中指定新文件的路径。

此连接命令文件就可以使用了。修改后的 xcl文件指定程序在片内 ROM中运行。 

如果要求连接后的程序在 RAM中运行，只需修改前面 4条命令就可以了。     

-DRAMSTART=0x20000000 

-DRAMEND=0x2000FFFF 

-DROMSTART=RAMSTART 

-DROMEND=RAMEND 

 

上面的命令先规定片内 RAM地址范围。然后将片内 ROM地址范围指向与 RAM相同的空间。编译连

接后的文件可以通过 FlashLoader直接下载到片内 RAM，并将 STR710的 BOOT0和 BOOT1脚设置成从

RAM引导，Reset后就可以在 RAM运行了。 

下面是两个完整的连接命令文件例子。请注意其中-Z命令的用法的差异，但连接处理结果是一样的。 
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连接命令文件例 1（在 ROM中运行）： 

// Code memory in flash 

-DROMSTART=0x40000000                          定义片内 ROM起始地址        

-DROMEND=0x4003FFFF                            定义片内 ROM结束地址 

-DVECSTART=ROMSTART                           定义 INTVEC段起始地址 

// Data memory 

-DRAMSTART=0x20000000                          定义片内 RAM起始地址 

-DRAMEND=0x2000FFFF                            定义片内 RAM结束地址 

-carm 

-Z(CODE)INTVEC=VECSTART:+0x428                 把 INTVEC段放在 ROM起始地址，保留 428字节      

-Z(CODE)ICODE,DIFUNCT=ROMSTART-ROMEND      把段 ICODE和 DIFUNCT顺序放在片内 ROM空间 

-Z(CODE)SWITAB=ROMSTART-ROMEND              把段 SWITAB顺序放在片内 ROM空间 

-Z(CODE)CODE=ROMSTART-ROMEND                把段 CODE顺序放在片内 ROM空间 

-Z(CONST)CODE_ID=ROMSTART-ROMEND           把段 CODE_ID顺序放在片内 ROM空间 

-Z(CONST)INITTAB,DATA_ID,DATA_C=ROMSTART-ROMEND  

把段 INITTAB，DATA_ID和 DATA_C放在片内 ROM空间 

-Z(CONST)CHECKSUM=ROMSTART-ROMEND         把段 CHECKSUM顺序放在片内 ROM空间 

-Z(DATA)DATA_I,DATA_Z,DATA_N=RAMSTART-RAMEND 

把段 DATA_I，DATA_Z和 DATA_N顺序放在片内 RAM空间

-Z(DATA)CODE_I=RAMSTART-RAMEND               把段 CODE_I顺序放在片内 RAM空间 

-QCODE_I=CODE_ID                                 把 CODE_ID中的内容拷贝到 CODE_I 

-D_CSTACK_SIZE=1000                              给堆栈 CSTACK分配 1000字节  

-D_SVC_STACK_SIZE=100                            给堆栈 SVC_STACK分配 100字节 

-D_FIQ_STACK_SIZE=100                             给堆栈 FIQ_STACK分配 100字节 

-D_ABT_STACK_SIZE=100                            给堆栈 ABT_STACK分配 100字节 

-D_UND_STACK_SIZE=100                            给堆栈 UND_STACK分配 100字节 

-D_IRQ_STACK_SIZE=400                             给堆栈 IRQ_STACK分配 400字节 

-D_HEAP_SIZE=400                                   给堆 HEAP分配 400字节 

-Z(DATA)CSTACK+_CSTACK_SIZE=RAMSTART-RAMEND         把上述堆栈顺序放在片内 RAM中 

-Z(DATA)SVC_STACK+_SVC_STACK_SIZE=RAMSTART-RAMEND 

-Z(DATA)ABT_STACK+_ABT_STACK_SIZE=RAMSTART-RAMEND 

-Z(DATA)UND_STACK+_UND_STACK_SIZE=RAMSTART-RAMEND 

-Z(DATA)FIQ_STACK+_FIQ_STACK_SIZE=RAMSTART-RAMEND 

-Z(DATA)IRQ_STACK+_IRQ_STACK_SIZE=RAMSTART-RAMEND 

-Z(DATA)HEAP+_HEAP_SIZE=RAMSTART-RAMEND 
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连接命令文件例 2： （连接结果和第一个例子一样） 

-carm 

-Z(CODE)INTVEC=40000000-40000428 

-Z(CODE)ICODE,DIFUNCT=40000000-4003FFFF 

-Z(CODE)SWITAB=40000000-4003FFFF 

-Z(CODE)CODE=40000000-4003FFFF 

-Z(CONST)CODE_ID=40000000-4003FFFF 

-Z(CONST)INITTAB,DATA_ID,DATA_C=40000000-4003FFFF 

-Z(CONST)CHECKSUM=40000000-4003FFFF 

-Z(DATA)DATA_I,DATA_Z,DATA_N=20000000-2000FFFF 

-Z(DATA)CODE_I=20000000-2000FFFF 

-QCODE_I=CODE_ID 

-Z(DATA)CSTACK+1000=20000000-2000FFFF 

-Z(DATA)SVC_STACK+100=20000000-2000FFFF 

-Z(DATA)ABT_STACK+100=20000000-2000FFFF 

-Z(DATA)UND_STACK+100=20000000-2000FFFF  

-Z(DATA)FIQ_STACK+100=20000000-2000FFFF 

-Z(DATA)IRQ_STACK+400=20000000-2000FFFF 

-Z(DATA)HEAP+400=20000000-2000FFFF 
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下表对上面出现的段名做一简单介绍： 

段名 功 能 说 明 段类型 属性 

INTVEC 
保存 Reset和异常向量，含跳转到 cstartup或中断服务程序的指令。必须在

0x00-0x3F地址范围内。 
CODE 只读 

ICODE 保存启动代码，位于能被 INTVEC中的转移指令达到的前 32MB字节内。 CODE 只读 

DIFUNCT 包含指向 C++建构模块的指针。该模块在调用main之前由 cstartup执行。 CODE 只读 

SWITAB 保存软件中断向量表 CODE 只读 

CODE 保存程序代码，可以在 ROM中执行。 CODE 只读 

CODE_I 
上电后保存声明为_ramfunc 的程序代码，掉电后丢失。初始化时从

CODE_ID（ROM）拷贝到 CODE_I中，然后在 RAM中执行。 
DATA 读/写 

CODE_ID 
永久性保存声明为_ramfunc 的程序代码。这些代码初始化时从 CODE_ID

拷贝到 CODE_I中（RAM），然后在 RAM中执行。 
CONST 只读 

INITTAB 保存需要在启动时初始化的段地址和段长度表格。 CONST 只读 

DATA_ID 
保存 DATA_I段中变量的初值，这些值在系统初始化时由 cstartup从 

DATA_ID拷贝到 DATA_I。 
CONST 只读 

DATA_C 保存常数数据，包括文字字符串 CONST 只读 

CHECKSUM 保存段的校验和 CONST 只读 

DATA_I 
保存声明为非零初值的静态全局变量，其初值开始在 DATA_ID中，系统初

始化时由 cstartup从 DATA_ID拷贝到 DATA_I。 
DATA 读/写 

DATA_Z 保存声明初值为零或没有声明初值的静态全局变量 DATA 读/写 

DATA_N 保存非易失存储器中，用_no_init关键字声明的静态全局变量 DATA 读/写 

CSTACK C/C++内部数据堆栈（用户模式） DATA 读/写 

SVC_STACK 操作系统堆栈（管理模式，用于具有特权的操作系统任务） DATA 读/写 

ABT_STACK 数据访问中止模式堆栈（用于虚拟存储器及存储器保护） DATA 读/写 

UND_STACK 未定义指令中止模式堆栈（支持硬件协处理器软件仿真） DATA 读/写 

FIQ_STACK 快中断模式堆栈（用于高速数据传输或通道处理） DATA 读/写 

IRQ_STACK 中断模式堆栈（用于通用中断处理） DATA 读/写 

HEAP 
堆（Heap）是 C\C++中为malloc和 free 或 new和 delete保留的动态分配

存储空间。 
DATA 读/写 

表 2-2. 段名及其功能 

 

表 2-2中属性中的 CODE是在 ROM中的代码。CONST是在 ROM 中的数据，DATA是在 RAM中的

数据。表 2-2中列出的所有段除了 INTVEC必须放在运行存储器（不管是 ROM还是 RAM）的 0-3F地址

空间和 ICODE必须放在前 32MB空间外，其他的段都可以放在符合其属性存储器空间的任何地址。 
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第三章．编译和连接应用程序 
1．编译连接处理 

选择主菜单 Project > Make，或选中工作区中的项目名 STR710-LED – Debug，按鼠标右键在弹出菜

单中选择 Make。EWARM将执行编译连接处理，生成可调试代码文件。Build消息窗口中将显示连接处理

的消息。连接的结果将生成一个带调试信息的代码文件 STR710-LED.d79和一个存储器分配（MAP）文件

STR710-LED.map。同时生成项目中汇编源程序和 c源程序的 lst文件。编译连接后的工作区窗口如图 2-11

所示。 

 

图 2-11. 编译连接处理后的项目文件结构 

从编译连接后的工作区窗口中树结构中，我们可以看到每个源文件访问关联了哪些头文件，同时生成了

哪些输出文件。因为我们在建立新项目时选择 Debug配置，所以在 My projects目录下自动生成一个 Debug

子目录。Debug子目录下又包含另 3个子目录，名字分别为 List、Obj、Exe。它们的用途如下： 

 List目录存下放列表文件，列表文件的后缀是 lst； 

 Obj 目录下存放 Compiler 和 Assembler 生成的目标模块文件，这些文件的后缀为 r79，可以用作 IAR 

XLINK连接器的输入文件； 

   Exe目录下存放可执行文件，这些文件的后缀为 d79，可以用作 IAR C-SPY调试器的输入文件，注意

在执行连接处理之前这个目录是空的。 
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2．查看汇编器/编译器List文件 

编译连接处理中难免发现各种各样错误。出错后用户可以从 Build消息窗口中获得错误信息，也可以从

List文件中获得错误信息。  

双击Workspace窗口中的*.lst文件，就可以打开该 List文件，它包含以下信息： 

 文件头 — 显示编译器的版本信息，列表文件生成时间，source 文件、list 文件和 object 文件的名字

和路径，编译命令行及选件等信息。 

 文件体  —  显示为每条源语句生成的汇编代码和二进制代码，以及变量如何被分配到不同的           

段。 

 文件尾 — 显示所需的堆栈、程序代码以及数据存储器的总量，同时报告错误和警告信息。 

 

3．查看MAP文件 

双击Workspace中的 STR710-LED.map文件名，编辑器窗口中将显示该 MAP文件。从 MAP文件中

我们可以了解以下内容： 

 文件头中显示连接器版本，输出文件名以及连接命令使用的选件。 

 CROSS REFERENCE 部分显示程序入口地址。 

 RUNTIME MODEL部分显示使用的运行时模块的属性。 

 MODULE MAP 部分显示所有被连接的文件。每个文件中，作为应用程序一部分加载的有关模块的信

息，包括各段和每个段中声明的全局符号都列出来。 

 SEGMENTS IN ADDRESS ORDER 部分列出了组成应用程序的所有段的起始地址和结束地址，字节

数，类型和对齐标准等。 

 END OF CROSS REFERENCE部分显示总的代码和数据字节数。 

 

如果编译连接没有任何错误，则生成 STR710-LED.d79应用程序代码，并可以用于在 IAR C-SPY中调

试。 
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第四章 用 C-SPY调试应用程序 
编译连接生成的 STR710-LED.d79 现在可以用 C-SPY 调试器进行调试。用户利用调试器可以查看变

量、设置断点、观察反汇编代码、监视寄存器和存储器、在 Terminal I/O窗口打印输出。 

1．设置Debugger选件 

在开始调试之前必须为 C-SPY调试器设置选件，具体操作如下。选择主菜单 Project > Option，选择

Category中的 Debugger。 

 在 Setup页面，在 Driver的下拉菜单中选择 J-Link/J-Trace，同时选择 Run to main（见图 3-1）。如

果用户没有购买 IAR的 JTAG仿真器，可选择 Simulator模拟执行。 

 

 
图 3-1. Debugger选件设置 

 

 在 Download页面，选择 veryfy download和 Use flash loader，见图 3-2。 

    要进行应用程序的调试，必须将生成的STR710-LED.d79文件下载到目标系统MCU的Flash或RAM中。

调试器C-SPY是通过一个叫做Flash Loader的程序完成下载任务的。Flash Loader的详细工作原理以及

它和C-SPY的互动机理我们不在这里介绍，用户可以参阅IAR的Flash Loader Guide。前面我们在设置

General Options选件时，已经指定目标MCU是ST STR710。所以EWARM已经提供了该芯片默认的

Flash Loader。如果用户选用的MCU不在EWARM的Device清单中，那就必须自己去编写该芯片的

Flash Loader了。 

按 Download页面（图 3-2）中的 Edit按钮，在弹出的 Flash Loader Overview对话框（图 3-3）中按

new…按钮。弹出Flash Loader Configuration对话框（图3-4）。因为我们要求把应用程序下载到STR710

的内部 Flash中，所以选择 Relocate并输入起始地址 0x40000000，按 OK键确认。 
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图 3-2. 设置 Downloader参数 

 

 
图 3-3. 设置 Flash Loader参数 

 

 
图 3-4. 设置 Flash Loader下载起始地址 

 

 Debugger的其它两个设置页面 Extra Options和 Plugins可以采用默认值。现在按 OK键完成设置。 
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2．加载应用程序 

选择主菜单 Project > Debug 或工具条上的 Debugger 按钮或者按键 CTL+D，C-SPY 将开始装载

STR710-LED.d79。屏幕上将显示 PC机通过 J-Link加载的过程。屏幕上除了已经原先已经打开的窗口外，

将显示一组 C-SPY专用窗口。如 Debug Log和 Disassembly窗口。见图 3-5。 

 

图 3-5. EWARM的 Debug窗口 

     

     注意：EWARM开发环境有两种工作状态，编辑状态和调试状态。进入和退出调试状态可以分别用工

具条上的 Debug 和 Stop Debugging按钮。 

 

3．组织窗口 

S-SPY可以固定窗口（所谓 dock），也可以将多个窗口组织成书签形式，也可以让它们浮动。改变浮

动窗口的大小时其他窗口不受影响。双击或用鼠标拖动窗口标题栏就可以改变窗口的形式。 

 

4．在源语句上调试 

EWARM有以下调试功能： 

① 检查源语句，双击Workspace中的 main.c，编辑器窗口显示该文件； 

② 用 Debug > Step Over命令（或 F10）步进函数调用语句； 

③ 用 Debug > Step Into命令（或 F11）进入函数内部；当执行 Step Into后，编辑窗口上的激活窗口

将切换到被进入的函数。 

注意：Step Over命令用来执行源程序中的一条语句或一条指令，即使这条语句是一函数调用语句。而

Step Into命令则进入到函数或子程序调用的内部。 
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④ 还有一些其他调试命令，如 Step Out（Shift+F11），Go（F5），Next statement，Break，Reset， 

Autostep等。用户可以用这些命令灵活地执行自己的调试任务。 

 

5．查看变量 

C-SPY允许在源程序上查看变量或表达式，并在执行程序过程中跟踪它们的值的变化。查看变量的方

法有以下几种，它们的功能有一定的区别，用户可以根据自己的需要和喜好使用这些工具。至于更详细的

信息请查看 EWARM USER GUIDE中的Working with variables and expressions章节。 

① Tooltip watch 

   在 Debug状态下，把光标对准编辑窗口中变量名，在该变量的旁边将显示其数据类型和当前值。 

 

 
图 3-6. Tooltip工具显示变量值 

② Auto 窗口 

Auto 窗口自动显示当前语句的和其周围相关的变量和表达式的值，单步执行程序时可以观察这些

变量如何变化。打开 Auto 窗口的方法是双击变量名、使该变量名变成高亮度。然后选择主菜单 View 

→ Auto命令。图 3-7是一个 Auto窗口的例子。 

 

 

 

 

 

 

                                图 3-7. Auto窗口中检查变量 
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③ Watch 窗口 

   打开 Watch 窗口的方法是选择主菜单 View → Watch 命令。把变量添加到 Watch 窗口方法是选

中变量（使其变成高亮度），然后用鼠标将其拖进 Watch 窗口。或者用鼠标右键在弹出菜单中选

择 Add to Watcn。请注意：Watch窗口和 Auto窗口可以平铺显示也可以按书签形式显示。用户可

以使用鼠标变换窗口显示方式。 

 

 

 

 

 

 

 

 

   

 

 

 

 

图 3-8. Watch窗口 

 

图 3-8是Watch窗口的例子，它与 Auto窗口以书签方式显示。Watch窗口和 Auto窗口是最常用的

变量观察窗口，实际上用户运用这两个窗口已经可以方便地进行变量查看了。 

④ Locals 窗口 

打开 Locals 窗口的方法是选择主菜单 View → Locals命令。此窗口自动显示局部变量，即当前活

跃函数的自动变量和参数。 

⑤ Live Watch 窗口 

   打开 Live Watch 窗口的方法是选择主菜单 View → Live Watch命令。Live Watch 窗口用于观察

静止位置上的变量，如全局变量。变量的值在执行时连续变化。 

                                  

6．设置和监视断点 

IAR C-SPY 具有强大的断点功能。详细请见 EWARM USER GUIDE 中的 131 页 The breakpoint 

system。设置断点最简单的方法是将光标定位到某条语句，然后按鼠标右键选择 Toggle Breakpoint命

令。 

① 设置断点 

点击要设置断点的语句，按鼠标右键，选择 Toggle Breakpoint（Code）。也可以按工具条上的 Toggle   
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Breakpoint按钮。这时该语句上将出现断点标记。 

 

 

图 3-8. 设置断点和 Breakpoint窗口 

 

选择主菜单 View > Breakpoint可以打开 Breakpoint窗口观察断点设置情况。图 3-8中的下部窗口

是 Breakpoint 窗口。C-SPY 不限制断点设置的数量，但是任何时候最多只允许激活一个断点。在

Breakpoint 窗口中定义断点语句的前面小方框中打勾的是被激活的断点。用户可以在 Breakpoint

窗口中切换激活的断点，达到调试的目的。  

② 执行到断点 

按 F5键或工具条上的 Go按钮都可以让程序执行到断点。Debug Log窗口将显示关于断点的信息。 

③ 清除断点 

双击 Breakpoint窗口中带勾的方框，可以允许或禁止断点。用主菜单 Edit > Toggle Breakpoint或

按鼠标右键选择 Toggle Breakpoint，可以直接从 Breakpoint窗口删除该断点。 

 

7．在反汇编窗口上调试 

通常，在 C\C++程序上调试应该更快速和更直接。但是如果用户希望在反汇编程序上调试，C-SPY 也

提供了这种功能，而且 C-SPY允许方便地在两种方式上切换。反汇编程序的调试方法如下： 

① 按 Reset按钮复位应用程序。 

② 调试时反汇编窗口通常是打开的。如果没打开可选择主菜单 View > Disassembly打开反汇编窗口。 
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                              图 3-8. 反汇编窗口 

③ 反汇编窗口如图图 3-8所示，汇编代码与 C语句一一对应。执行单步命令时将执行单条汇编语句。 

④ 如果关闭反汇编窗口，单步命令重新执行单条 C语句。 

 

8．监视寄存器 

寄存器窗口允许用户监视和修改 STR710寄存器的内容。选择主菜单 View > Register打开寄存器窗口，

见图 3-9。 

 

图 3-9. 寄存器窗口 
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    图 3-9显示的是 CPU寄存器。C-SPY允许检查 STR710的所有寄存器。用户可以从寄存器窗口左上

方的下拉菜单中选择需要查看的任何寄存器组。 

 

9．查看存储器 

用户可以在存储器窗口监视所选择的存储器区域。 

① 选择主菜单 View >Memory打开存储器窗口，见图 3-10（用 8-bit显示数据）。 

② 激活 main.c 窗口并双击某个变量名并用鼠标将其拖到存储器窗口。执行单步，同时观察存储器的

内容是如何修改的。用户可以在存储器窗口修改存储单元的内容。只需把插入点放在希望修改的地

方，然后输入新值就可以了。 

 
图 3-10. 存储器窗口 

10．观察Terminal I/O 

当用户希望调试应用程序中的stdin和stdout，但是又没有实际的硬件支持时，C-SPY允许用户使用

Terminal I/O模拟stdin和stdout。在本例中没有用到此功能。 

注意：Terminal I/O只有在选用了 Linker选件With I/O emulation module时才可用。也就是说，某些

把 stdin和 stdout指向 Terminal I/O的低级例程将被连接进应用程序。 

选择主菜单 View > Terminal I/O显示 I/O操作的输出，见图 3-12。Terminal I/O窗口显示的内容取决

于应用程序执行了多远。 

 

 

 

 

 

 

 

 

 

                               图 3-12. Terminal I/O窗口     
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10．执行程序和暂停程序 

① 按 F5键，选择主菜单 Debug > Go或工具条上的 Go按钮都可以直接运行程序。如果没有设置断点，

程序一直执行到结束。因为在本例中程序设计成无限循环，用户需要停止程序运行可以选择主菜单

Debug → Break。Debug Log窗口中显示程序运行状态的消息。       

② 如果要求复位应用程序，选择主菜单 Debug > Reset或工具条上的 Reset按钮。 

③ 如果要退出 C-SPY，选择 Debug > Stop Debugging，或工具条上的 Stop Debugging按钮。 

C-SPY 还提供许多其他的调试功能，如宏和中断模拟等，在再线帮助 Help 下的 ARM Embeded 

Workbench USER GUIDE中有详细介绍。 
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第五章 如何编写 ST ARM应用程序 
ARM芯片生产商为了推销自己的产品，通常都为每一款新芯片设计和生产可以展示该芯片所有功能或

主要功能的评估板，同时提供 Demo 程序的源码和所有片上外设的驱动程序。这些源程序通常都是高手写

成，所以打算使用该芯片的用户用不着自己再花力气开发底层程序。ST 公司也是如此。我们在下面以 ST

的 STR710为例，帮助初学者理解 c语言 ARM应用程序的组织结构，学习如何利用 ST公司提供的底层程

序开发自己的应用程序。 

我们先介绍 ST 公司为 STR710 提供了哪些底层程序及每个程序的功能。然后再详细介绍其中几个重

要程序。最后介绍如何利用这些资源编写自己的程序。 

1． ST 公司为 STR710 提供的源程序   

源 文 件 头 文 件 功                      能 

71_init.s  启动程序。在进入 c语言的 main( )之前完成对芯片的初始化，存储器分配及地址重映射。 

71x_vect.s  定义 Reset、异常和外设中断向量表。 

71x_it.c 71x_it.h 所有异常和片上外设的中断服务程序。全是空函数，由用户根据需要添加内容。 

 71x_map.h 以结构的形式描述所有片上外设的控制、状态和数据寄存器。同时定义每种片上外设基地址。

 71x_type.h 定义统一的项目数据类型。 

 71x_conf.h 芯片配置文件。只需把目标系统所用外设名前面的 // 符号去掉就可定制目标系统配置。 

 71x_lib.h 根据配置文件包含相应的外设头文件 

71x_lib.c  给外设结构指针赋初值（基地址） 

adc12.c Adc12.h 12位 A/D转换器的设备驱动程序和头文件 

apb.c apb.h APB总线设备驱动程序和头文件 

bspi.c bspi.h BSPI接口设备驱动程序和头文件 

can.c can.h CAN总线设备驱动程序和头文件 

eic.c eic.h EIC中断控制器驱动程序和头文件 

flash.c flash.h 片内 FLASH驱动程序和头文件 

gpio.c gpio.h GPIO驱动程序和头文件 

i2c.c i2c.h I2C总线驱动程序和头文件 

pcu.c pcu.h 电源管理控制程序和头文件 

rccu.c rccu.h RCCU控制程序和头文件 

rtc.c rtc.h RTC控制程序和头文件 

uart.c uart.h UART驱动程序和头文件 

wdg.c wdg.h WatchDog驱动程序和头文件 

xti.c xti.h 外部中断控制程序和头文件 

表 5-1. STR710源程序清单 
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2．几个主要程序的功能介绍 

建立一个最小结构的 ARM项目，至少需要以下几个程序： 

 71x_init.s 

 71x_vect.s 

 71x_it.c 

 71x_it.h 

 71x_map.h 

 main.c 

其中 71x_init.s 是启动程序。71x_vect.s 生成中断向量表即段 INTVEC。71x_it.c存放中断服务程序，

该文件只列出函数框架，用户根据需要填写服务程序内容。main是主函数。我们在前面介绍 EWARM时举

的例子 STR710-LED就是一个最简单结构的 ARM应用例子。请注意，在 71x_it.c文件中的定时器中断服

务程序中添加了以下内容： 

U32 counter=1;                              // 在文件开始时定义全局变量 counter 

 

void T1TIMI_IRQHandler(void) 

{ 

 TIM1->SR &= ~0x2000;                      // 清除 TIM1 中断标志 

 GPIO2->PD = GPIO2->PD <<1 ;              // 轮流开通和关闭 LED显示  

 counter++; 

 if (counter>4) 

 {counter=1; 

 GPIO2->PD = 0x0800; } 

} 

其主程序如下： 

#include "71x_map.h" 

int main(void) 

{ 

  EIC->SIR[19] |= 0x00000001;               // 配置通道 19的优先级 

  EIC->IER |= 1<<19;                        // 开放通道 19的中断 

 EIC->ICR |= 0x00000001;                  // 允许中断 

// 把 GPIO2 配置成 Push-Pull output模式 

  GPIO2->PC0 = 0xFFFF ; 

  GPIO2->PC1 = 0x0000 ; 

  GPIO2->PC2 = 0xFFFF ; 
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  GPIO2->PD = 0x0800  ;                   // 复位引脚 

  // 配置 TIM1 

  TIM1->CR2 &= ~0x2000; 

  TIM1->CR2  = 0x2009; 

  TIM1->CR1  = 0x8000; 

  TIM1->CNTR = 0xFFFF; 

  while(1);                                  // 无限循环 

} 

 

启动运行上面的简单程序后，STR71-EVAL评估板上的 4个发光二极管 LD11，LD12，LD13 和 LD14

无限制地循环点亮。LED的轮流点亮是中断服务程序 T1TIMI_IRQHandler中执行的。而定时器 1的配置和

启动是在主程序 main 中完成的。在大家注意，上述程序中用到结构指针 TIM1、EIC 和 GPIO，这些都是

在 71x_map.h文件中定义的。我们在后面将对其做进一步介绍。 

 

① 启动程序的功能 

什么是启动程序？它干什么用？其实在编写 8051的 C语言程序时就有启动程序，它完全是 C编译器生

成的，很多人只是没注意到罢了。例如，用户如果在 main( )之前定义了一个数据数组，而且还赋予每个元

素以初值。那么这个赋初值的任务就是由启动程序完成的。 

下面让我们深入查看本手册例子中 71x_init.s的内容。 

; 程序状态处理器模式域设置值，对应于 CPSR中的 0-5位 

Mode_USR           DEFINE   0x10       ; 用户模式 

Mode_FIQ            DEFINE   0x11       ; 快中断模式 

Mode_IRQ            DEFINE   0x12       ; 中断模式 

Mode_SVC            DEFINE   0x13       ; 管理模式 

Mode_ABT            DEFINE   0x17       ; 中止模式 

Mode_UNDEF         DEFINE   0x1B       ; 未定义指令模式 

Mode_SYS            DEFINE   0x1F        ; 系统模式 

I_Bit                  DEFINE   0x80        ; I Bit置 1时，,禁止 IRQ  

F_Bit                 DEFINE   0x40         ; F Bit置 1时，禁止 FIQ 

 

EIC_Base_addr       DEFINE   0xFFFFF800   ; EIC 基地址 

ICR_off_addr         DEFINE   0x00          ; Interrupt Control register 偏移量 

CIPR_off_addr        DEFINE   0x08          ; Current Interrupt Priority Register偏移量 

IVR_off_addr         DEFINE   0x18           ; Interrupt Vector Register偏移量 
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FIR_off_addr         DEFINE   0x1C           ; Fast Interrupt Register偏移量 

IER_off_addr       DEFINE   0x20          ; Interrupt Enable Register偏移量 

IPR_off_addr       DEFINE   0x40          ; Interrupt Pending Bit Register偏移量 

SIR0_off_addr      DEFINE   0x60          ; Source Interrupt Register 0偏移量 

 

EMI_Base_addr      DEFINE   0x6C000000  ; EMI基地址 

BCON0_off_addr     DEFINE   0x00         ; Bank 0 configuration register偏移量 

BCON1_off_addr     DEFINE   0x04         ; Bank 1 configuration register偏移量 

BCON2_off_addr     DEFINE   0x08         ; Bank 2 configuration register偏移量 

BCON3_off_addr     DEFINE   0x0C         ; Bank 3 configuration register偏移量 

 

EMI_ENABLE         DEFINE   0x8000      ; 允许 EMI Bank ( Bit 15=1) 

EMI_SIZE_16         DEFINE   0x0001      ; 16位宽度设置值 (Bit 0=1) 

 

GPIO2_Base_addr    DEFINE   0xE0005000  ; GPIO2 基地址 

PC0_off_addr        DEFINE   0x00          ; Port Configuration Register 0 偏移量 

PC1_off_addr        DEFINE   0x04          ; Port Configuration Register 1 偏移量 

PC2_off_addr        DEFINE   0x08          ; Port Configuration Register 2 偏移量 

PD_off_addr         DEFINE   0x0C          ; Port Data Register 偏移量 

 

CPM_Base_addr     DEFINE   0xA0000040    ; CPM (MCLK Divide Control Register ) 基地址 

BOOTCR_off_addr   DEFINE   0x10           ; CPM - Boot Configuration Register偏移量 

FLASH_mask        DEFINE   0x0000         ; to remap FLASH at 0x0 

RAM_mask          DEFINE   0x0002         ; to remap RAM at 0x0 

 

;|----------------------------------------------------------------------------------| 

;| - APB Bridge  (System Peripheral)                                               | 

;|----------------------------------------------------------------------------------| 

APB1_base_addr     DEFINE   0xC0000000      ; APB Bridge1基地址 

APB2_base_addr     DEFINE   0xE0000000      ; APB Bridge2基地址 

CKDIS_off_addr      DEFINE   0x10             ; APB Bridge1 - Clock Disable Register偏移量 

SWRES_off_addr     DEFINE   0x14             ; APB Bridge1 - Software Reset Register偏移量 

CKDIS1_config_all    DEFINE   0x27FB          ; To enable/disable clock of all APB1's peripherals 

SWRES1_config_all   DEFINE   0x27FB          ; To reset all APB1's peripherals 

CKDIS2_config_all    DEFINE   0x7FDD          ; To enable/disable clock of all APB2's peripherals 
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SWRES2_config_all   DEFINE   0x7FDD          ; To reset all APB2's peripherals 

;--------------------------------------------------------------- 

; ?program_start 

;--------------------------------------------------------------- 

  MODULE ?program_start               ; 开始一个库模块 

  RSEG IRQ_STACK:DATA(2)     

         RSEG FIQ_STACK:DATA(2) 

  RSEG UND_STACK:DATA(2) 

  RSEG ABT_STACK:DATA(2)   

  RSEG SVC_STACK:DATA(2) 

  RSEG CSTACK:DATA(2) 

  RSEG ICODE:CODE:NOROOT(2)     ; NOROOT指定此段中如果没有代码，在连接时可抛弃 

  PUBLIC __program_start               ; Export symbles to other module 

  EXTERN ?main                        ; Import an external symble  

                CODE32                        ; Generate 32-bit ARM instruction 

;******************************************************************************* 

;   定义两个宏 

;******************************************************************************* 

;* Macro 名       : EIC_INIT                

;*功能            : 定义初始化 EIC的宏，执行以下操作 

;                 - 禁止 IRQ 

;                 - 禁止 FIQ  

;                 - 中断向量寄存器 IVR 包含 load PC opcode (0xF59FF00) 

;                 - 当前优先级=0 

;                 - 禁止所有中断通道 

;                 - 所有中断优先级=0 

;                 - 所有 SIR 寄存器包含到相关 IRQ表入口的偏移量 

;* Input          : 无 

;* Output         : 无 

;******************************************************************************* 

EIC_INIT   MACRO 

        LDR     r3, =EIC_Base_addr 

        LDR     r4, =0xE59F0000 

        STR     r4, [r3, #IVR_off_addr]             ; Write the LDR pc,[pc,#offset] 

                                                  ; instruction code in IVR[31:16] 
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        LDR     r2, =32                           ; 32 Channel to initialize 

        LDR     r0, =T0TIMI_Addr                ; Read the address of the IRQs 

                                                 ; address table 

        LDR     r1, =0x00000FFF 

        AND     r0,r0,r1 

        LDR     r5, =SIR0_off_addr               ; Read SIR0 address 

        SUB     r4,r0,#8                         ; subtract 8 for prefetch 

        LDR     r1, =0xF7E8                     ; add the offset to the 0x00000000 

                                                 ; address(IVR address + 7E8 = 0x00000000) 

                                                 ; 0xF7E8 used to complete the 

                                                 ; LDR pc,[pc,#offset] opcode 

        ADD     r1,r4,r1                         ; compute the jump offset 

EIC_INI MOV     r4, r1, LSL #16                   ; Left shift the result 

        STR     r4, [r3, r5]                        ; Store the result in SIRx register 

        ADD     r1, r1, #4                        ; Next IRQ address 

        ADD     r5, r5, #4                        ; Next SIR 

        SUBS    r2, r2, #1                        ; Decrement the number of SIR registers 

                                                  ; to initialize 

        BNE     EIC_INI                         ; If more then continue 

        ENDM 

;******************************************************************************* 

;* Macro 名      : PERIPHERAL_INIT 

;* 功能          : 复位所有外设. 

;* Input          : 无. 

;* Output         : 无 

;******************************************************************************* 

PERIPHERAL_INIT MACRO 

        LDR     r1, =APB1_base_addr            ; r0= APB1 base address 

        LDR     r2, =APB2_base_addr            ; r0= APB2 base address 

        LDR     r0, =CKDIS1_config_all 

        STRH    r0, [r1, #CKDIS_off_addr]         ; Clock Disabling for all APB1 peripherals 

        LDR     r0, =CKDIS2_config_all 

        STRH    r0, [r2, #CKDIS_off_addr         ; Clock Disabling for all APB2 peripherals 

        LDR     r0, =SWRES1_config_all 

        STRH    r0, [r1, #SWRES_off_addr]        ; Keep under reset all APB1 peropherals 
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        LDR     r0, =SWRES2_config_all 

        STRH    r0, [r2, #SWRES_off_addr]        ; Keep under reset all APB2 peropherals 

        MOV     r7, #10                          ; Wait that the selected macrocells exit from reset 

loop1   SUBS    r7, r7, #1 

        BNE     loop1 

        MOV     r0, #0 

        STRH    r0, [r1, #SWRES_off_addr         ]; Enable all all APB1 peropherals 

        STRH    r0, [r2, #SWRES_off_addr         ]; Enable all all APB2 peropherals 

        STRH    r0, [r1, #CKDIS_off_addr]          ; Clock Enabling for all APB1 peripherals 

        STRH    r0, [r2, #CKDIS_off_addr]          ; Clock Enabling for all APB2 peripherals 

        MOV     r7, #10                           ; Wait that the selected macrocells exit from reset 

loop2   SUBS    r7, r7, #1 

        BNE     loop2 

        ENDM 

;******************************************************************************************************** 

; 重映射请求 

; Reset后，STR710的两个引脚 BOOT0和 BOOT1的状态（外部设定）被锁存进 BOOT配置 

; 寄存器 PCU_BOOTCR中（0xA0000050）。引导方式通常由此两引脚决定，但是在启动程序 

; 中允许在 Reset后由软件修改硬件设置。如果用户希望在启动程序中规定引导方式，可以删除 

; 下面的注释符号。这样 BOOT引脚上的设置将不影响引导方式。  

;          #define   remapping 

; 然后确定将哪块存储器映射到地址 0x00000000 

; 如果希望重映射到 RAM，删除下一行的注释 

;         #define  remap_ram 

;  如果希望重映射到 FLASH，则删除下一行的注释 

;         #define remap_flash 

 

        IMPORT  T0TIMI_Addr                    ; 定义外部符号 T0TIMI_Addr 

__program_start 

         LDR     pc, =NextInst 

NextInst 

  NOP                                 ; Wait for OSC stabilization 

  NOP 

  NOP 

  NOP 



 
EWARM应用入门指南 万利电子有限公司 整理 

地址：南京市新模范马路17号02幢2层 电话：025-83235502 / 83235503 
邮编：210003 传真：025-83235501 

38

  NOP 

  NOP 

  NOP 

  NOP 

  NOP 

;****************************************************************************************************** 

; ARM处理器支持 7种运行模式，其中 6种是特权模式，一种是用户模式。除用户模式和系 

; 统模式外其他都是异常模式。每种处理器模式使用不同的寄存器组，并有自己独立的物理 

; 寄存器 R13(SP)。所以在初始化时要将 SP指向其运行模式的栈空间。堆栈的大小和地址 

; 是在连接命令文件中定义的。 

;****************************************************************************************************** 

        MSR     CPSR_c, #Mode_ABT|F_Bit|I_Bit 

        ldr     sp,=SFE(ABT_STACK) & 0xFFFFFFF8     ; 指向 ABT_STACK栈底 

 

        MSR     CPSR_c, #Mode_UNDEF|F_Bit|I_Bit 

        ldr     sp,=SFE(UND_STACK) & 0xFFFFFFF8     ; 指向 UND_STACK栈底 

 

        MSR     CPSR_c, #Mode_SVC|F_Bit|I_Bit 

        ldr     sp,=SFE(SVC_STACK) & 0xFFFFFFF8     ; 指向 SVC_STACK栈底 

     

; 如果要求复位所有外设，删除下一行注释 

;       PERIPHERAL_INIT                               ; 调用宏 PERIPHERAL_INIT 

 

; 如果要求初始化 EIC，删除下一行注释 

        EIC_INIT                                        ; 调用宏 EIC_INIT 

 

;****************************************************************************** 

;REMAPPING  根据前面的重映射请求决定是否做重映射处理 

;Description  :  Remapping  memory whether RAM,FLASH 

;               at Address 0x0 after the application has started executing. 

;               Remapping is generally done to allow RAM  to replace FLASH 

;               at 0x0. 

;               the remapping of RAM allow copying of vector table into RAM 

; 下面的程序修改 BOOTCR[1:0]的内容。 

;****************************************************************************** 
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#ifdef remapping 

    #ifdef remap_flash 

        MOV     r0, #FLASH_mask 

    #endif 

    #ifdef remap_ram 

        MOV     r0, #RAM_mask 

    #endif 

        LDR     r1, =CPM_Base_addr    

        LDRH    r2, [r1, #BOOTCR_off_addr]           ; 读 BOOTCR 的低 2位 

        BIC     r2, r2, #0x03                          ; 清除 BOOTCR 的低 2位 

        ORR     r2, r2, r0                             ; 根据 R0修改 BOOTCR的低 2位 

        STRH    r2, [r1, #BOOTCR_off_addr]            ; 写回 BOOTCR 寄存器 

#endif 

        MSR     CPSR_c, #Mode_FIQ|I_Bit            ; Change to FIQ mode 

        ldr     sp,=SFE(FIQ_STACK) & 0xFFFFFFF8     ; 指向 FIQ_STACK栈底 

 

        MSR     CPSR_c, #Mode_IRQ|I_Bit; Change to IRQ mode 

        ldr     sp,=SFE(IRQ_STACK) & 0xFFFFFFF8     ; 指向 IRQ_STACK栈底 

 

        MSR     CPSR_c, #Mode_USR                 ; Change to User mode, Enable IRQ and FIQ 

        ldr     sp,=SFE(CSTACK) & 0xFFFFFFF8        ; 指向 CSTACK(user) 栈底 

 

; 现在跳转到 C 库函数?main 

        b ?main                                        ; 注意只能用指令 B不能用 BL，因为不再返回。         

        LTORG 

        END 

 

 

从上面的 STR710-LED的启动程序清单中我们可以看到，启动程序执行以下任务： 

 定义了 CSPR寄存器中处理器模式控制字段的值和中断控制字段值； 

 定义了 EIC、EMI、GPIO、APB1和 APB2的基地址和相关控制寄存器的偏移量； 

 定义了各种处理器模式的堆栈； 

 定义了初始化 EIC和外部设备的 2个宏； 

 决定是否重映射； 

 加载各处理器模式的堆栈指针 
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 跳转到 C的库程序?main 

上面 STR710-LED 的启动程序在很多情况下是可以通用的，几乎不做任何修改就可以用于其他项目。

当然有时候也需要做一定的修改才能使用。建议初学者先直接引用这个启动程序，等到熟悉以后再根据项

目需要做修改。 

 

② 71x_vect.s 

   71x_vect.s建立 Reset、异常中断处理程序以及外设中断的向量表，初学者可以直接引用这个启动程序。 

 

③ 71x_it.c和 71x_it.h 

   71x_it.c中包含所有中断服务程序的空函数，用户可以选择加进自己中断服务程序。就象前面介绍的。 

 

④ 71x_cofg.h 

   71x_cofg.h是目标系统配置文件，它是用户开发自己的项目时唯一要修改的文件。用户应根据目标板上

使用到的芯片资源定制自己的项目配置文件，方法是删除使用设备前面的注释。注意，在 STR710-LED例

子中没有利用 71x_cofg.h。请看下面例子： 

 

#ifndef __71x_CONF_H 

#define __71x_CONF_H 

/* Comment the line below to put the library in release mode */ 

#define DEBUG          

#define inline inline 

 

/* 系统不用的设备名前加注释 */ 

#define _ADC12                          /* 起用 ADC12 */ 

 

/* #define _APB */ 

/* #define _APB1 */ 

/* #define _APB2 */ 

/* #define _BSPI */ 

/* #define _BSPI0 */ 

/* #define _BSPI1 */ 

/* #define _CAN */ 

/* #define _EIC */ 

/* #define _EMI */ 

/* #define _FLASH */ 
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#define _GPIO                           /* 起用 GPIO 0和 1 */ 

#define _GPIO0 

#define _GPIO1 

/* #define _GPIO2 */ 

/* #define _I2C */ 

/* #define _I2C0 */ 

/* #define _I2C1 */ 

 

#define _PCU                                  /* 起用 PCU */ 

#define _RCCU                                 /* 起用 RCCU */ 

 

/* #define _RTC */ 

/* #define _TIM */ 

/* #define _TIM0 */ 

/* #define _TIM1 */ 

/* #define _TIM2 */ 

/* #define _TIM3 */ 

 

/* #define _UART */ 

/* #define _UART0 */ 

/* #define _UART1 */ 

/* #define _UART2 */ 

/* #define _UART3 */ 

/* #define _USB */ 

/* #define _WDG */ 

/* #define _XTI */ 

/* #define _IRQVectors */ 

 

#endif /* __71x_CONF_H */ 

 

       在这个例子中我们为目标系统配置了 ADC12、GPIO0、GPIO1、 PCU和 RCCU这几个设备。 
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⑤ 71x_map.h 

在 71x_map.h 文件中以结构的形式定义片上外部设备的控制、状态和数据寄存器。我们以 12 位 A/D

为例： 

 定义 AD转换器寄存器组的结构如下： 

   typedef volatile struct 

{ 

          vu16 DATA0; 

          vu16 EMPTY1[3];        // EMPTY是寄存器之间的空地址单元（6个字节） 

          vu16 DATA1; 

          vu16 EMPTY2[3]; 

          vu16 DATA2; 

          vu16 EMPTY3[3]; 

          vu16 DATA3; 

          vu16 EMPTY4[3]; 

          vu16 CSR; 

          vu16 EMPTY5[7]; 

          vu16 CPR; 

} ADC12_TypeDef;  

 

 定义 A/D转换器寄存器组的基地址 

因为 A/D转换器连接在 APB2总线上，先定义 APB2的基地址 

#define APB2_BASE       0xE0000000 

 

然后根据偏移量定义 A/D转换器寄存器组的基地址 

#define ADC12_BASE  (APB2_BASE + 0x7000) 

 

⑥ 71x_lib.c 

71x_lib.c根据用户的配置文件（71x_conf.h）自动初始化目标系统起用的外设指针。仍以 A/D转换器为

例，见下面： 

    

       #ifdef _ADC12 

            ADC12 = (ADC12_TypeDef *) ADC12_BASE 

       #endif 
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此后用户在应用程序中需要引用 A/D转换器的某个寄存器时只需用以下方法即可： 

ADC12->CSR  = 0x00 ;   

 

⑦ 71x_lib.h 

71x_lib.h 根据用户的配置文件（71x_conf.h）包含需要访问的头文件，还是以 ADC12 举例来说明。

如果我们在 71x_conf.h中配置了 AD转换，即删除了#define _ADC12前的注释。那么在 71x_lib.h中

有： 

        

#ifdef _ADC12 

            #include “adc12.h” 

        #endif 

 

 

注意： ST的所有源文件最初是为 RealView开发环境编写的。在 RealView中其输出代码是否带调试信息

是根据在 71x_cofg.h中是否保留语句 #define DEBUG决定的。在 71x_map.h 中有 #ifdef DEBUG的定

义。而在 IAR EWARM开发环境中，输出 DEBUG还是 RELEASE版本，是在 EWARM开发环境中选择的。

用户应注意在利用 ST的源程序时应该怎样处理两者之间关系。 

      

3．如何利用 ST 源程序着手编写应用程序 

写到这里相信大家已经看出着手编写 ST STR710 的应用程序是多么容易了。为了清晰起见，我们把

流程列在下面： 

① 建议备份 ST的 01STR71x软件包，以防无意修改或破坏。 

② 建立新工作区和新项目，并根据前面介绍设置项目选件。 

③ 给项目添加文件。必须添加的文件有： 

71x_init.s   （注：在项目下建立一个 startup组，把 71x_init.s和 71x_vect.s放在此组）       

71x_vect.s 

71x_it.c     （注：如不需要定时器 1的中断处理，就把 void T1TIMI_IRQHandler(void)函数内部写空） 

71x_lib.c 

目标系统所用到设备驱动 c程序； 

④ 在连接器指向的 include目录中，必须包含以下文件 

71x_it.h 

71x_map.h 

71x_type.h 

71x_conf.h 
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71x_lib.h 

至少包含目标系统所用到设备的头文件(﹡.h)，一般 include目录应包含所有头文件； 

⑤ 根据用户目标系统的外设配置要求修改 71x_cong.h文件； 

⑥ 添加或编写用户自己的 main主程序，在程序头上添加语句 #include 71x_lib.h，在程序中调用 ST提供

的外设驱动程序完成自己的操作需求。 

 

01STR71x 软件包中有很多单个的片上外设的例子。初学者可以去再试验和了解如何操作这些设备。

其中有一个关于 STR710-EVAL的 12位 A/D转换的例子在“GettingStarted”目录下。用户可以直接点击

此目录下的 Led_Dimmer工作区名打开。你可以打开主程序窗口和Watch窗口，调节电位器（改变 AD的

输入电压），同时单步运行程序并观察变量 Value的变化。 

 

还有一点提示：由于 ARM 结构不提供位操作指令，所以对寄存器的位置位和位清除可以用下面语句

形式实现。 

GPIO0 -> PC0  |= 1<<3;                   // 将 GPIO0的 PC0控制寄存器的 bit 03置 1 

GPIO0 -> PC0  |= 0x0008;                 // 与上面一句的结果一样 

EMI -> BCON0 = 0 | (1<<15) | (0x01<<2) |1;   // 将 BCON0寄存器的 bit 15，bit 2和 bit 0置 1，其

// 他位置 0。 

 

 

 

 


