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C2000 Getting Started with Code Composer
Studio v4
Chinese (中文) translation

Introduction
Because Code Composer Studio v4.0 (CCSv4) is now based on the open-source Eclipse 3.2 IDE, there are a number
of changes between Code Composer Studio v3.x (CCSv3.x) upon which all legacy C2000 collateral is based. This
wiki explains in detail how C2000 collateral can be migrated from CCSv3.x to CCSv4, and helps users get started
with their first CCSv4.0 programs.
For all generic CCSv4 topics which are not C2000-specific, or to better understand CCSv4 in more detail, please
visit the Code Composer Studio Wiki at:

• Code Composer Studio v4

Starting Up CCSv4

Select a workspace
When you first open CCSv4, a dialog box will prompt you to select a workspace. This is a folder where all of your
CCSv4 custom settings will be saved for your specific personal computer. This includes all of your project settings,
macros, and views when you shut down CCSv4. For instance, if you have several projects + memory windows +
graph window + watch variables that you were working with when you closed CCSv4, these same projects and
settings will be available when you re-open CCSV4.

Workspaces save automatically when you close CCSv4. If you don't want to overwrite the settings you have for a
current workspace, you can open/ switch to a new workspace by going to: "File-> Switch Workspace".
Note that workspaces are not portable in CCSv4 because they contain data specific to your computer system. So you
cannot save a workspace, zip it up, and send it to another user.

http://processors.wiki.ti.com/index.php?title=CN_C2000_Getting_Started_with_Code_Composer_Studio_v4
http://processors.wiki.ti.com/index.php?title=Code_Composer_Studio_v4
http://processors.wiki.ti.com/index.php?title=File:1_workspace_launcher.jpg
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Run Your First C2000 Project in CCSv4

Open the CCSv4 cpu_timer project included with the C2833x/2823x C/C++ Header Files
and Peripheral Examples (v1.30 or later)
• Go to Project->Import Existing CCS/CCE Eclipse Project

• Next to “Select root directory:” click on the “Browse” button and browse to the <header file
base>/DSP2833x_examples_ccsv4/cpu_timer directory folder and select “OK”. Make sure
“Example_2833xCpuTimer” is selected in the “Projects:” textbox. Do NOT check the “Copy projects into
workspace” checkbox. Click on the “Finish” button.

• You are now in the C/C++ Perspective view. The project files appear in the “C/C++ Projects” window.
• Under Binaries – after the project is built, the .out file for the project is located here.
• Under Includes – All directories with include referenced by the build options are listed here. Expanding the

directories lists all .h and .inc files in these directories which may or may not be used by the project.
• Under Debug – all debug files are located here, including .map and .obj files.
• Afterwards, all source files are listed. If any source files contain functions, include files, or structures, selecting

the “cross” next to the source file lists all the function, include file, and structure names in that file.
Double-clicking the function names brings you to where the function, include file, and structures are defined in
the source code.

http://processors.wiki.ti.com/index.php?title=File:2_import_existing.jpg
http://processors.wiki.ti.com/index.php?title=File:3_import_ccsv4_existing.jpg


C2000 Getting Started with Code Composer Studio v4 3

Set up the Target Configuration Options for Device Emulation
• For the current example, to set up an emulator target configuration, go to “Target->New Target Configuration”
• Type a name for the target configuration file. It will have a “.ccxml” suffix. Leave the “Use default location” box

checked, and select “Finish”.

• In the window that appears, select your emulator via the “Connection” pull-down list. Then in the “Device” list,
select your device. In this example, we have selected the “Spectrum Digital XDS510USB Emulator” and the
“TMS320F28335” device checkbox.

http://processors.wiki.ti.com/index.php?title=File:4_example_projectview.jpg
http://processors.wiki.ti.com/index.php?title=File:5_target_configuration.jpg
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• Then go to “File->Save”.
• Now go to “View->Target Configuration”
• Under “User-Defined”, you will see your new target configuration .ccxml file. Right-click the file.

• Select “Link File to Project ->”Example_2833xCpuTimer”, to always use this target configuration for this
specific project in your workspace.

• Or select “Set as Default” if you want to use this emulator and device GEL file by default for all future projects
opened in your workspace that do not have a target configuration assigned to them.

http://processors.wiki.ti.com/index.php?title=File:6_basic_target_config_setup.jpg
http://processors.wiki.ti.com/index.php?title=File:7_link_target_config.jpg
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Build and Load Project
• To Build the Project, Connect to the Target, and Load the active project into the target all at once, click on the

green bug (Debug) button on the toolbar. Then skip the "Reset the CPU" step below

• To build the project without automatically connecting the target and loading the active project object code into the
device, go to “Project->Build Active Project”.

• Then select the down-arrow next to the green bug on the toolbar and select “Launch TI Debugger”. You are now
in the “Debug” perspective view.

• Go to “Target->Connect Target”, to connect to the target device.

• Go to “Target->Load Program” and browse to “Example_2833xCpuTimer.out” (in the “/cpu_timer/Debug”
directory)

Reset the CPU
Select “Target->Reset->Reset CPU” to reset the device. To restart the program, select “Target->Restart”.

Add Watch Variables to Watch Window
• If “Example_2833xCpuTimer.c” is not already open, in the upper right-hand corner of screen, click on the small

C/C++ icon to switch back to “C/C++” Perspective and open the source file. Then click on the small Debug icon
in the upper right-hand corner of the screen with the green bug next to it to switch back to the “Debug”
Perspective.

• In “Example_2833xCpuTimer.c”, scroll down in the Comments at the top of the file until you reach “Watch
Variables”. Highlight “CpuTimer0.InterruptCount”, right-click, and select “Add Watch Expression”. Then repeat
for “CpuTimer1.InterruptCount” and “CpuTimer2.InterruptCount”. These variables are now in the watch window.

http://processors.wiki.ti.com/index.php?title=File:8_debug_toolbar.jpg
http://processors.wiki.ti.com/index.php?title=File:9_build_active_project.jpg
http://processors.wiki.ti.com/index.php?title=File:10_launch_debugger.jpg
http://processors.wiki.ti.com/index.php?title=File:11_connect_target.jpg
http://processors.wiki.ti.com/index.php?title=File:12_debug_perspective.jpg
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Enable real-time mode to monitor the watch variables as they are changing
• Go to “Tools->Debugger Options”. In the window that opens, scroll down to "Realtime Options" and select

“Enable silicon real-time mode (service critical interrupts when halted, allow debugger accesses while running)”.
Then select “Yes” if a dialog box pops up asking if you want to allow real-time switching.

• In the upper right-hand corner of the watch window, click on the white down-arrow and select “Customize
Continuous Refresh Interval…”. Change the Continuous Refresh Interval to “1” (second) instead of the default “5”
(seconds).

• In the upper right-hand corner of the watch window, click on the icon of the yellow arrows rotating in a circle
over a pause sign to enable continuous refresh mode so watch variables will continuously refresh in real-time
while the program is running.

Run the program
• Select the green arrow icon on the toolbar or go to "Target->Run"

• Watch the variables in the Watch Window increment once per second as the CPU timers interrupt.

• Congratulations!! You just finished running your first C2000 project in CCSV4!

http://processors.wiki.ti.com/index.php?title=File:13_add_watch_exp.jpg
http://processors.wiki.ti.com/index.php?title=File:14_realtime_options.jpg
http://processors.wiki.ti.com/index.php?title=File:15_cont_refresh_interval.jpg
http://processors.wiki.ti.com/index.php?title=File:16_refresh_icon.jpg
http://processors.wiki.ti.com/index.php?title=File:17_run_icon.jpg
http://processors.wiki.ti.com/index.php?title=File:18_example_watchwindow.jpg
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Migrating C2000 Projects from CCSv3.3 to CCSv4
Code Composer Studio v4 allows users to migrate projects from CCSv3.3 to CCSv4. The user has the flexibility of
migrating a single project at a time or multiple projects at once. This way, if there are many projects in a single
directory which need conversion from CCSv3.x to CCSv4, in one run, all the projects can be easily migrated.
To start the migration process, go to “Project->Import Legacy CCSv3.3 Project” to open the Project Migration
Wizard.

Migrating a Single Project from CCSv3.3 to CCSv4
• In the Project Wizard, select the “Select Project:” radio button and browse to the CCSv3.3 .pjt project file you

wish to migrate. In the below figure, the Example_2833xCpuTimer.pjt file is selected. Then hit the “Next” button.

• Next, select the Code Generation Tools version desired for building the selected project.

• If the legacy project included references to DSP/BIOS DELETE THEM even if your project does not use
DSP/BIOS (See C2000 Getting Started with Code Composer Studio
v4#Missing_Source_Files_Caused_by_References_to_DSP_BIOS for more details). Then the below screen will
not show up during migration. If you are using DSP/BIOS select the DSP/BIOS tools version used for the project.
Although the C2000 examples do not use DSP/BIOS by default, because the .PJT file includes an empty reference
to the “DspBiosBuilder”, the migration wizard will select a default DSP/BIOS tools version. Hit the “Next” button.

http://processors.wiki.ti.com/index.php?title=File:19_migrate_project.jpg
http://processors.wiki.ti.com/index.php?title=File:20_select_pjt_migrate.jpg
http://processors.wiki.ti.com/index.php?title=File:21_migrate_codegentools.jpg
http://processors.wiki.ti.com/index.php?title=C2000_Getting_Started_with_Code_Composer_Studio_v4%23Missing_Source_Files_Caused_by_References_to_DSP_BIOS
http://processors.wiki.ti.com/index.php?title=C2000_Getting_Started_with_Code_Composer_Studio_v4%23Missing_Source_Files_Caused_by_References_to_DSP_BIOS
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• De-select “Use common root for all migrated projects” to allow CCS to automatically determine the unique
common root for all files referenced by the project and click “Finish”. (For more detailed information on defining
a “common root” for project migration and the generated macros.ini file, see Portable Projects in CCSv4 for
C2000).

• Congratulations! You have migrated a CCSv3.x project to CCSv4. In your project folder, you can now delete all
files except:

1. .cdtproject
2. .cdtbuild
3. .project
4. Any source files and header files (.c,.asm,.h,.inc,.cmd,.lib, etc.) in the project directory
There is no need to keep the CCSv3.3 .pjt file.

Migrating Multiple Projects at Once from CCSv3.3 to CCSv4
• In the Project Wizard, select the “Select search-directory:” radio button and browse to the directory holding all or

some of the CCSv3.3 project folders you wish to migrate. In the below figure, the directory selected is:
“C:/tidcs/c28/DSP2833x/v130/DSP2833x_examples/”. The migration wizard will then search for all legacy
projects under the selected directory, and these projects will appear in the “Discovered Legacy Projects:” box.
Check those projects you wish to migrate. Then hit the “Next” button.

• Next, select the Code Generation Tools version desired for building the selected projects (same as with single
project migration).

http://processors.wiki.ti.com/index.php?title=File:22_migrate_dspbios.jpg
http://processors.wiki.ti.com/index.php?title=Portable_Projects_in_CCSv4_for_C2000
http://processors.wiki.ti.com/index.php?title=Portable_Projects_in_CCSv4_for_C2000
http://processors.wiki.ti.com/index.php?title=File:23_singleproject_commonroot.jpg
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• If the legacy projects included references to DSP/BIOS, select the DSP/BIOS tools version used for the project.
Although the C2000 examples do not use DSP/BIOS by default, because the .PJT file includes an empty reference
to the “DspBiosBuilder”, the migration wizard will select a default DSP/BIOS tools version. Hit the “Next” button.
(same as with single project migration)

• Next, select the Code Generation Tools version desired for building the selected projects (same as with single
project migration).

• If the legacy projects included references to DSP/BIOS, select the DSP/BIOS tools version used for the project.
Although the C2000 examples do not use DSP/BIOS by default, because the .PJT file includes an empty reference
to the “DspBiosBuilder”, the migration wizard will select a default DSP/BIOS tools version. Hit the “Next” button.
(same as with single project migration)

• In the Set Advanced Options window, select the “Use a common root for all migrated projects” checkbox. This
checkbox is used when multiple projects share a common root directory for files included in those projects.

For instance, the below figure shows the directory file structure for the projects being migrated. All projects to be
migrated for this example are located in individual folders in the “DSP2833x_examples” directory. All of these
projects include common header, source files, and libraries, under the DSP2833x_common and DSP2833x_headers
directories which, in turn, are located under the “v130” root directory.

http://processors.wiki.ti.com/index.php?title=File:Migrate_multiple_pjts.jpg
http://processors.wiki.ti.com/index.php?title=File:Multiple_pjts_common_root.jpg
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Because all the projects being migrated use common files under the “C:/tidcs/c28/DSP2833x/v130” root directory,
the “Path” specified should be “C:/tidcs/c28/DSP2833x/v130”. Select also, a unique “Path-variable name”, which
serves as a macro/replacement name for typing out the entire path. For this example, we have chosen
“INSTALLROOT_2833X_V130”.
Note: In a given workspace, a path variable name/macro can only be defined only once for a particular path. In other
words, “INSTALLROOT_2833X_V130” cannot be defined again for another project for a different path in the same
workspace. Instead, a different path variable/macro must be defined. You can read more about macros and their
usefulness when transferring projects from user to user or PC to PC on the following page: Portable Projects in
CCSv4 for C2000.
When finished, click the “Finish” button.
• Congratulations! You have migrated multiple CCSv3.x projects to CCSv4. In your project folders, you can now

delete all files except:
1. .cdtproject
2. .cdtbuild
3. .project
4. Any source files and header files (.c,.asm,.h,.inc,.cmd,.lib, etc.) in the project directory
There is no need to keep any CCSv3.3 .pjt files.

Known Migration Issues

"No rule to make target" Error
The following build error(s) may occur with some imported projects:

C:\Program Files\Texas Instruments\ccsv4\utils\gmake\gmake -k all

C:\Program Files\Texas Instruments\ccsv4\utils\gmake\gmake: *** No rule

 to make target `myFile.obj', needed by `myApp.out'.

...

In those cases, right-click on the project with errors and select "Build Properties" from the menu. Under "C2000
Compiler->Directory Specifier:", examine the contents of the "Object file directory (default is .)(--obj_directory,
-fr)". If the directory is identical to the contents of "Temporary file directory" or "Assembly file directory" (i.e.
"<path>/Debug"), then there will be an error.
You can resolve the issue by:

http://processors.wiki.ti.com/index.php?title=File:Directory_structure.jpg
http://processors.wiki.ti.com/index.php?title=Portable_Projects_in_CCSv4_for_C2000
http://processors.wiki.ti.com/index.php?title=Portable_Projects_in_CCSv4_for_C2000
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1. Changing this path to any other location.
2. Delete contents of the box.

Fig. 15: Build Properties - Object File Directory

Missing Source Files Caused by References to DSP
BIOS

By default, DSP/BIOS is not supported in the Microcontroller Core
(code-size limited) version of CCStudio v4.0.0 as of RTM (July 20,
2009).
The problem is:
1. If you are using the Microcontroller Core (code size limited)

version of CCStudio v4.0, while migrating your project which has the reference to Tool="DspBiosBuilder" at the
top of the .pjt file, you will receive a screen titled "Select DSP/BIOS Tools" with your example name next to a
"Tool Version" of "0.0.0". The project appears to finish migrating, but none of your source files will link properly
to your project, and building the project will fail.

2. If you are using the full Platinum version of CCStudio V4.0, your project will migrate fine, and the migration tool
will automatically fill in the DSP/BIOS tool version with whatever version fo DSP/BIOS has been installed with
CCStudio v4.0. The project will also build fine. BUT: if you send your CCSv4 project to anyone using the
Microcontroller Core version of CCStudio v4.0, they will not be able to build the project.

If your .PJT file has the text: Tool="DspBiosBuilder" near the top under the [Project Settings]
category:Remove this before running the project migration tool in Code Composer Studio v4.x. ORDownload
DSP/BIOS 5.40 and XDCtools/RTSC into the same directory as your /ccsv4/ folder (default is C:/Program
Files/Texas Instruments/) and restart CCSv4. The download link is: Download DSP/BIOS and XDCtools/RTSC
here.
NOTE: This issue will be resolved in Code Composer Studio v4.0.1 which will be issued to Code Composer
Studio v4.0.0 users via an auto-notification patch download. At that time, the Microcontroller Core (Code-size
limited) version of Code Composer Studio will no longer have migration issues with CCSv3.3 projects which
included references to the DspBiosBuilder tool.

Errors with "hello world" project using F281x Devices
Users who attempt to build the generic "hello world" template project via Code Composer Studio v4 Getting Started
while setting any of the 281x (2812, 2811, 2810) devices as the target processor, may see the following errors:

"../2812_RAM_lnk.cmd", line 86: error: placement fails for object 

".text", size

0x182a (page 0). Available ranges:

PRAMH0 size: 0xffe unused: 0xf89 max hole: 0xf89

error: errors encountered during linking; "Test.out" not built

This is because the "printf" command used in the "hello world" project takes a large amount of memory which is not
available on the 2812 devices. The 281x linker command file, 2812_RAM_lnk.cmd, by default does not define
enough memory for code (.text) to support the "printf" command.
For getting started on the 2812, users should instead start with the CCSv4 peripheral examples in the 2812 C/C++ 
Header Files and Peripheral Examples software package [2]. A good "first project" to get started with is the "cpu

http://processors.wiki.ti.com/index.php?title=File:CCSv4_import_pjt16.PNG
http://focus.ti.com/docs/toolsw/folders/print/sprc097.html
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timer" project following the same instructions on this wiki page as were used for 2833x devices.

Portable Projects in CCSv4 for C2000 (macros/linked variables/etc.)
Refer to: Portable Projects in CCSv4 for C2000.

Target Configurations: Device Target and Emulation Setup
With Code Composer Studio v3.3, in order to configure the device emulation settings for a target, the user must open
the Setup CCStudio v3.3 utility, which is independent of the Code Composer Studio IDE to select the correct
emulator and device GEL file for CCStudio. This then requires the user to close the CCStudio IDE and run the setup
utility every time the target or emulator changes.
Code Composer Studio v4 includes emulator target configuration within the CCSv4 IDE itself. The user can specify
different target configurations for different emulators and device settings either for general use, or for specific
projects.
To see existing Target Configurations on your computer:
1. Go to “View-> Target Configurations”.
2. Any target configurations you have created will be under “User Defined”.

To create a new target configuration (this MUST be done prior to anything you do on any device):
1. Go to “Target-> New Target Configuration” OR in the Target Configurations window, click on the “New” icon

(leftmost icon in toolbar at top of window): 
2. Select a File Name for your target configuration (for instance, F28335_XDS510USB.ccxml, if you are using an

F28335 device and an XDS510USB emulator).
3. Then select the “Use shared location” checkbox to save your new target configuration to the default location on

your PC where CCSv4 looks for target configuration files, OR uncheck the box and select a project to associate
the target configuration file to a particular project in the workspace.

4. Hit the “Finish” button and follow the instructions on the “Cheat Sheet” that appears to select your “Connection”
(emulator) and “Device”.

Programming to C28x Flash
An improvement in CCSv4 over CCSv3.3 is that the flash-programmer plug-in is now built into CCSv4. When you
debug a project which has its source code and command linker file configured for flash memory, you no longer need
to load the symbols only and then separately use the flash programmer plugin to program the code to flash. Instead,
as long as the correct device target configuration is loaded, if CCSv4 detects that there is code in flash memory via
the command linker file in your project, it will automatically program the relevant code to flash when you load your

http://processors.wiki.ti.com/index.php?title=Portable_Projects_in_CCSv4_for_C2000
http://processors.wiki.ti.com/index.php?title=File:Target_configurations_view.jpg
http://processors.wiki.ti.com/index.php?title=File:Target_config_new_icon.jpg
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program.
To set up the flash programming settings and program to flash memory in CCSv4:
1. First ensure that your target configuration is set up properly for your device.
2. Go to "Target-> Launch TI Debugger"
3. In Debug view, go to "Tools->On-chip Flash"
4. Configure Flash settings – you can erase Flash from here as well.
5. Then you can either: Click on the Debug “bug” icon, or Go to "Target->Debug Active Project", OR Go to

"Target->Load program" and select the .out file you want to program. The CCSv4 IDE will automatically
program/load the code to the appropriate memory locations in flash and/or RAM, similar to how code is
automatically loaded to RAM for RAM-based projects.

Note: Source code and linker command files still have to be pre-configured for Flash options the same as with
CCSv3.3 (For instructions on how to do this, see your device-specific C/C++ Header Files and Peripheral Examples
Quickstart Readme document located in the /docs folder of the install package)
For more information on Flash Programming for the 28x with CCSv4, visit the Code Composer Studio v4 Wiki page
link: Flash_Programming_F28x

C2000 GEL File Migration
The device gel files from CCSv3.3 still work with CCSv4.0. Calls to manipulate projects (i.e. Build Project) and
“WatchAdd()” functions to add variables to the watch window are no longer supported. GEL hotmenu items now
appear in the “Scripts” pull-down menu.
More information on GEL files, including how to load GELs and which GEL functions are still supported can be
found at the CCSv4 GEL Wiki page here: GEL
Register WatchAdd() in Device GEL Replaced by View->Registers

The C2000 device GEL files include “WatchAdd()” functions to all the peripheral registers, allowing the user to 
quickly add any peripheral’s registers to the watch window in CCSv3.x when not using the TI-provided C/C++ 
header files. Because the WatchAdd() function no longer works in CCSV4, the peripheral registers are now available 
via the Registers window, which can be accessed from "View->Registers". If using the TI-provided C/C++ header 
files (downloadable from device product folders on the TI website) while debugging, register structures defined in 
the header files can also be added to the Watch Window same as before. Expanding these register structures allows 
access to individual bit fields as well (i.e., adding "AdcRegs" to the Watch Window, will display all the ADC

http://processors.wiki.ti.com/index.php?title=File:Flash_options.jpg
http://processors.wiki.ti.com/index.php?title=Flash_Programming_F28x
http://processors.wiki.ti.com/index.php?title=GEL
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registers and their bit field expansions).

Enabling Function Profiling with CCSv4 for C28x Devices
To enable HW function profiling with CCSv4 for C28x:
• Browse to <INSTALL DIR>\ccsv4\DebugServer\bin\win32\SerializedProfileActivities
• Open 'ProfileFunctionsHW.prof_ini' in a text editor
• Under the list of ISA, add 'TMS320C28' to the list
• Save file and restart CCSv4
• The 'ProfileFunctionsHW.prof_ini' would now look something like:
[Name] Profile all Functions for CPU Cycles 

[Events]
dataclass.pcdt.events.Cycles
dataclass.pcdt.events.CPU Cycles
dataclass.pcdt.events.cycle.Total
[EventClasses]
pcdt
[ISA]
TMS320C28
TMS320C56
TMS320C55
TMS320C621x
TMS320C641x
TMS320C671x
TMS470R1
TMS470R2
TMS470R3
TMS470Rd
TMS470Re

HW Function Profiling is breakpoint based and not recommended for cases where there are a limited amount of
breakpoints available (such as code in persistent memory like flash).
Note that function profiling for C28x is not officially supported (untested).

CN C2000 Getting Started with Code Composer Studio v4
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License
THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER
APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.
BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE
A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.
License
1. Definitions
1. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or

phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work
that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in
timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.

2. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(f) below,
which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting
separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined below) for the purposes of this License.

3. "Creative Commons Compatible License" means a license that is listed at http:/ / creativecommons. org/ compatiblelicenses that has been approved by Creative Commons as being essentially equivalent to this License,
including, at a minimum, because that license: (i) contains terms that have the same purpose, meaning and effect as the License Elements of this License; and, (ii) explicitly permits the relicensing of adaptations of works made
available under that license under this License or a Creative Commons jurisdiction license with the same License Elements as this License.

4. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.
5. "License Elements" means the following high-level license attributes as selected by Licensor and indicated in the title of this License: Attribution, ShareAlike.
6. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.
7. "Original Author" means, in the case of a literary or artistic work, the individual, individuals, entity or entities who created the Work or if no individual or entity can be identified, the publisher; and in addition (i) in the case of a

performance the actors, singers, musicians, dancers, and other persons who act, sing, deliver, declaim, play in, interpret or otherwise perform literary or artistic works or expressions of folklore; (ii) in the case of a phonogram the
producer being the person or legal entity who first fixes the sounds of a performance or other sounds; and, (iii) in the case of broadcasts, the organization that transmits the broadcast.

8. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression
including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a
musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or
lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography,
topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not
otherwise considered a literary or artistic work.

9. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise
rights under this License despite a previous violation.

10. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to
make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the
communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.

11. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected
performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights
Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other
applicable laws.
3. License Grant
Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated
below:
1. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
2. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original

Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
3. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
4. to Distribute and Publicly Perform Adaptations.
5. For the avoidance of doubt:

http://creativecommons.org/compatiblelicenses
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1. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right
to collect such royalties for any exercise by You of the rights granted under this License;

2. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor waives the exclusive right to collect
such royalties for any exercise by You of the rights granted under this License; and,

3. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via
that society, from any exercise by You of the rights granted under this License.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and
formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved.
4. Restrictions
The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:
1. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or

Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License.
You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly
Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License.
This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from
any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(c), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable,
remove from the Adaptation any credit as required by Section 4(c), as requested.

2. You may Distribute or Publicly Perform an Adaptation only under the terms of: (i) this License; (ii) a later version of this License with the same License Elements as this License; (iii) a Creative Commons jurisdiction license
(either this or a later license version) that contains the same License Elements as this License (e.g., Attribution-ShareAlike 3.0 US)); (iv) a Creative Commons Compatible License. If you license the Adaptation under one of the
licenses mentioned in (iv), you must comply with the terms of that license. If you license the Adaptation under the terms of any of the licenses mentioned in (i), (ii) or (iii) (the "Applicable License"), you must comply with the
terms of the Applicable License generally and the following provisions: (I) You must include a copy of, or the URI for, the Applicable License with every copy of each Adaptation You Distribute or Publicly Perform; (II) You
may not offer or impose any terms on the Adaptation that restrict the terms of the Applicable License or the ability of the recipient of the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable
License; (III) You must keep intact all notices that refer to the Applicable License and to the disclaimer of warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform; (IV) when
You Distribute or Publicly Perform the Adaptation, You may not impose any effective technological measures on the Adaptation that restrict the ability of a recipient of the Adaptation from You to exercise the rights granted to
that recipient under the terms of the Applicable License. This Section 4(b) applies to the Adaptation as incorporated in a Collection, but this does not require the Collection apart from the Adaptation itself to be made subject to
the terms of the Applicable License.

3. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the
medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute,
publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the
extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with
Ssection 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The
credit required by this Section 4(c) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of
the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this
Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the
Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.

4. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections,
You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in
which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's
honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this
License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer
UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING
THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE,
NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT
ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.
6. Limitation on Liability
EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE
OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
7. Termination
1. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License,

however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
2. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different

license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this
License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous
1. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
2. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
3. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this

agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
4. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent.
5. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not

be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
6. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979),

the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject
matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the
standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the
license of any rights under applicable law.
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