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前言 

阅前必读 

简介： 

本用户指南是三相无刷电机驱动模板的使用说明书，详细描述了 SEED-BLDC 的硬件

构成、原理，以及它的使用方法和编程指导。 

保修： 

所有由北京合众达电子技术有限责任公司生产制造的硬件和软件产品，保修期为从发货

之日起壹年。在保修期内由于产品质量原因引起的损坏，北京合众达电子技术有限责任公司

负责免费维修或更换。当在保修期内软件进行了升级，北京合众达电子技术有限责任公司将

免费提供。 

产品注册： 

为了在保修期内获得免费的产品升级和技术支持，北京合众达电子技术有限责任公司强

烈建议：注册您所购买的每一件软／硬件产品。 

产品的注册过程非常简单，按下列步骤进行： 

  北京合众达电子技术有限责任公司的每一件产品几乎都带有产品光盘，光盘上有一

个名为 REGISTER.TXT 的文件，即为产品注册表。 
  如果没有找到 REGISTER.TXT 文件，请致电或发 Email 给我们，告知您的 Email

地址，我们会将此文件 Email 给您。 
  填写产品注册表中的各栏（用户名、通信地址、电话／传真、Email 地址、所购的

产品名和产品编号、和产品接收的日期等）。 
  通过 Email 或传真将产品注册表反馈给我们。 

注意：产品注册必须在产品发货之日起 90 天内完成。 

参考资料： 

TMS320C28X 系列 DSP 的 CPU 与外设（上）、（下）：介绍 TMS320C28X 系列 DSP
结构、原理和使用。 
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 IR2136：介绍三相桥驱动器的特点、原理、电气指标和引脚封装 

  HCNR200:介绍线性隔离放大器的特点、原理、电气指标和引脚封装 

商标： 

SEED 是北京合众达电子技术有限责任公司的注册商标。 

TI、XDS510 是 Texas Instruments 的注册商标。 
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第 1 章 

入门 

1.1 特点： 
  可以与 12V~36V 电机相连，电机额定电流不超过 4A 
  可以与有位置传感器和无位置传感器的无刷电机相连 
  对于有位置传感器的无刷电机，可以根据霍尔传感器进行换相；对于无位置传感器

的无刷电机，可以根据感应电动势进行换相 
  可以与编码器相连进行准确位置控制 
  速度检测和电流检测，可以进行闭环控制 
  可以进行正反转控制 
  驱动电路和控制电路完全隔离，避免驱动部分给控制部分带来干扰 
  可以与 SEED-DEC2407，SEED-DEC2812 相连。 

1.2 功能框图 

DSP 

PWM1

PWM3

PWM4

PWM5

PWM6

U

   V

W

EVA/
EVB

ADC

CAP/QEP

PWM2

 

图 1-1 功能框图  
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1.3 概述 

SEED-BLDC 系统主要包含两部分，分别为 SEED-BLDC 的硬件系统与相应的测试软

件。 

SEED-BLDC 采用驱动芯片+MOSFET 的形式，可以将直流母线电压逆变成交流电压来

达到对直流无刷电机的控制；SEED-BLDC 须与 SEED-DEC2812 相连，DSP 输出的 PWM
经过隔离送入驱动芯片，后经 MOSFET 来达到对电机的变频调速。 

相应的测试软件包括以下几个部分： 

  有位置传感器无刷电机的开环控制 
  有位置传感器无刷电机的闭环控制，采用 PID 控制 
  无位置传感器无刷电机的开环控制 
  若与实验箱连，与上位机相连的有位置传感器的无刷电机的闭环 PID 控制 

1.4 应用 

适用于无刷电机的控制场合，如电机控制、自动控制、工业驱动和高校教学实验系统等。 

1.5 技术指标 
  直流母线电压+12~36V 
  电机额定电流不超过 4A 
  电机霍尔传感器的供电电压+5V 
  可以与 SEED-DEC2812 相连，+5V 接口电平 
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第 2 章 

直流无刷电机控制原理 

2.1 简介 

目前，电机可以分为两类：直流电机和交流电机。直流电机是最早出现的电机，也是最

早实现调速的电机，具有良好的线性调速特性、简单的控制性能、高质高效平滑运转的特性，

不过由于电刷和换向器的存在阻碍了它的发展，逐渐被交流电机所取代。交流电机按照转子

材料等的不同，可以分为同步电机和异步电机，其中根据感应电动势的不同，同步电机可以

分为永磁同步电机和直流无刷电机，永磁同步电机的感应电动势为正弦波，直流无刷电机的

感应电动势为梯形波。 

直流无刷电机利用电子换相器件取代了机械电刷和机械换相器，因此不仅保留了直流电

机的优点，而且又具有交流电机结构简单、运行可靠、维护方便的特点。 

直流无刷电机的转子是由永磁材料制成的，具有一定的磁极对数的永磁体。无刷电机的

转子磁钢的形状呈弧形，产生梯形波感应电动势。 

直流无刷电机的工作离不开电子开关电路，因此由电动机本体、转子位置传感器和电子

开关电路三部分组成了直流无刷电机的控制系统，其原理框图如图 2-1，直流电源通过开关

电路向电动机定子绕组供电，位置传感器随时检测到转子所处的位置，并根据位置信号来控

制开关管的导通和截止，从而自动地控制了哪些绕组通电，哪些绕组断电，实现了电子换相。 

 

 

 

 

图 2-1 直流无刷电机的原理框图 

直流电源 开关电路 电机

位置传感器 
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图 2-2 三相星型连接全桥驱动电路 

实际应用中，由于受应用条件的限制，直流无刷电机常分为有位置传感器的无刷电机和

无位置传感器的无刷电机。 

2.2 变频调速原理 

交流电机的转速可由下式表示：  

60 (1 )fn s
p

= −  

 式中n —电机转速（r/min）； 

  p —电机磁极对数； 

  f —电源频率； 

  s —转差率。 

 由上式可知，影响电机转速的因素有：电机的磁极对数 p ，转差率 s 和电源频率 f 。 

 对于异步电机来说，转差率 s 不等于 0；而对于同步电机来说，转差率 s =0。由于直流

无刷电机为同步电机，对于某一电机，磁极对数 p 是固定的，所以只需改变电源频率就可

以达到变频调速的目的。 

 在这里是通过改变 DSP 输出 PWM 的占空比来达到对电机调速的目的。 
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2.3 有位置传感器的无刷电机的控制方法 

在大多数直流无刷电机的应用场合，电机常常带有霍尔位置传感器。位置传感器为转子

位置提供了最直接有效的检测方法。霍尔位置传感器是以霍尔效应做理论基础、以霍尔元件

为核心部件的磁敏传感器。 

在直流无刷电机的内部嵌有 3 个霍尔位置传感器，它们在空间上相差 120 度。由于电

机的转子是永磁体，当它在转动的时候，它所产生的磁场也随之转动，每个霍尔传感器都会

产生 180 度脉宽的输出信号，如图 2-3 所示,并且，三个霍尔传感器输出的信号互差 120 度。 

 

图 2-3 霍尔位置传感器输出波形相位关系 

对于单极对数的无刷电机，在每个机械转中共有 6 个上升或者下降沿，正好对应着 6

个换相时刻，因此根据这 6 个换相时刻便可以对电机进行换相，并且可以进行速度计算。 

2.4 无位置传感器的无刷电机的控制方法 

位置传感器为电机增加了体积，需要多条信号线，更增加了电动机制造的工艺要求和成

本。如果 3 个传感器安装的不对称，很容易出现换相时刻不准的问题。在有些场合，如油

压系统和风机，由于受条件的限制，往往需要无位置传感器的无刷电机控制。不过由于无传

感器的无刷电机启动力矩不足，因此其应用条件很有限。 

对无位置传感器的无刷电机的控制，感应电动势法是最常见和应用最广泛的一种方法。 

对于单极对数的三相直流无刷电机，每转 60 度就需要换相一次，每转一转需要换相 6
次，因此需要 6 个换相信号。如图 2-4，每相的感应电动势都有 2 个过零点，这样三相就有

6 个过零点。因此只需测量或者计算出这 6 个过零点，再将其延迟 30 度，就可以获得 6 个

换向信号。 
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图 2-4 直流无刷电机感应电动势波形 
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第 3 章 

直流无刷电机驱动模板的设计 

3.1 开关主电路的设计 

图 3-1 开关主电路的设计 

开关主电路主要是将直流母线电压逆变成交流电压来驱动无刷电机，由于上下桥臂功率

管导通顺序的不同以及导通时间的长短不同，从而使电机准确换向并且能达到变频调速。 

逆变电路由功率开关管 V1~V6 等组成，可以为功率晶体管 GTR、功率场效应管

MOSFET、绝缘栅极管 IGBT、可关断晶闸管 GTO 等功率电子器件。晶闸管适用于较大功

率电机，晶体管适用于中小功率电动机。有 3 种方法： 
  采用驱动芯片+IGBT 的形式，适用于大功率电机 
  采用智能功率模块（IPM）, 本身具有过压、欠压、过流和温度过高的保护功能，

但体积较大，价钱较高 
  采用驱动芯片+MOSFET 的形式，适用于中小电机 

 
在这里选用驱动芯片+MOSFET 的形式，DSP 输出的 PWM 经过光电隔离后送入驱动

芯片，由驱动芯片驱动 MOSFET。 

驱动芯片选用 International Rectifier 公司的 IR2136，此芯片为三相逆变器驱动器集成

电路，适用于变速电机驱动器系列，如直流无刷、永磁同步和交流异步电机等。其特点为： 
  600V 集成电路能兼容 CMOS 输出或 LSTTL 输出 
  门极驱动电源 10V~20V 
  所有通道的欠压锁定 
  内置过电流比较器 

驱动

芯片

V6

V4

V2

V5

V3

V1
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  隔离的高/低端输入 
  故障逻辑锁定 
  可编程故障清除延迟 
  软开通驱动器 

 
IR2136 的功能框图如图 3-2。 

图 3-2 IR2136 的功能框图 
 
IR2136 的输入/输出时序图如图 3-3。 

 

图 3-3 IR2136 的输入/输出时序图 
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其中HIN1,2,3为上桥臂的3个输入端，LIN1,2,3为下桥臂的3个输入端；HO1,2,3

和 LO1,2,3 分别为上桥臂和下桥臂的 3 个输出端。其中HIN1,2,3和LIN1,2,3都为反

向输出。FAULT 表示故障输出，低电平有效。 

 
IR2136 的典型连接图为图 3-4。 

 
图 3-4 IR2136 的典型连接图 

3.2 定子电流的检测 

实际中有时需要进行定子电流的检测，如果过流的检测等，可以采用两种方法： 

  通过检测电流的霍尔传感器，如 LEM 模块。 
  通过主回路中串采样小电阻的方法。 

本系统的电流比较小，选用串采样小电阻的方法。小电阻两端的电压经过有源滤波，

放大然后经过隔离后送入模数转换器 AD，通过 AD 采样来获得电流的大小。这里选用

线性隔离放大器 HCNR200，具有很好的线性度，信号带宽达到 1M，其原理如图 3-5。 

 

图 3-5 HCNR200 的原理图 
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其应用电路如图 3-6。 

 

图 3-6 HCNR200 应用电路图 

注：电流采样的具体实现参照原理图。在这里电流的采样主要用来进行过流保护等

功能。 

3.3 速度信号（或位置信号）的检测 
      对于有位置传感器的直流无刷电机，电机上集成霍尔元件，即转子位置传感器

上带有霍尔元件。传感器输出为三路高速脉冲信号 H1、H2 、H3 用于检测转子的

位置。根据转子位置信号改变电动机驱动电路中功率管的导通顺序，实现对电动机

转速和转动方向的控制。设计中，需将传感器的输出信号经过光隔后送入 DSP 的

CAP 单元，根据每个上升或者下降沿后 CAP 口的状态来决定位置和计算速度。对

于单极对数的电机，每个机械周期产生 6 个沿，每两个沿间的时间间隔代表 1/6 个

机械周期。 
由于传感器的输出信号常常带有一些干扰信号，所以在送入 DSP 的捕获单元 

时需要将其进行滤波，在这里选用的是施密特触发反相器，如 74LS14，传感器的

输出信号经过两次反向后送入 DSP 的捕获单元，达到了很好的滤波效果。 
  

      对于无位置传感器的直流无刷电机，由于不能直接通过传感器获得换相信号，

须通过检测感应电动势的过零信号来获得换相信号。将电机的相电压 Ua，Ub，Uc
和此时的电势 Vx=(Ua+Ub+Uc)/3。经过比较器，根据比较器的输出来决定如何换

相。如图 3-7。 
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图 3-7 无位置传感器的直流无刷电机过零点检测图 

 
注：由于无位置传感器的无刷电机启动力矩不足，应用条件比较有限，并且由

于经过电容滤波后延时，所以应用较少。 

3.4 直流母线电压的检测 

在这里采用 AD 采样的方式，直流母线电压通过电阻分压然后经过隔离后送入 AD，

通过 AD 采样就能知道此时母线电压的大小，可以用来进行过压或者欠压的检测等。 

3.5 各种电源的获得 

对于电机的驱动控制，由于驱动部分常常给控制部分带来干扰，这里采用隔离的方

式，将这两部分完全隔离，因此需要获得各种电源。在这里部分电源由外部电源获得，

部分电源经过电源芯片获得，如 TPS5430，可以将输入为 5.5V~36V 的电压转变为+5V
电压。系统中所需要的+15V 电源和-15V 电源可以将得到的+5V 的电源经过电源芯片

TPS65130 获得。 
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3.6 PWM 的产生 
TMS320F2812 的事件管理器模块有 EVA 和 EVB 两个。每个管理器包括通用定时

器（GP）、比较器、PWM 单元、捕获单元以及正交编码脉冲电路（QEP）。EVA 和

EVB 在功能上是完全相同的，只是在模块的外部接口和信号有所不同。 
TMS320F2812 每个模块可以产生 8 路 PWM，包括 3 对全比较单元产生的死区可

编程 PWM 信号以及由通用定时器比较器产生的 2 路独立的 PWM 信号。在这里选用的

是 3 对全比较单元产生的死区可编程 PWM 信号。 
PWM 的产生是以定时器为时基的。 
 定时器有 3 种方式： 
 

 

连续增 

 

连续增/减 
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定向增/减 

直流无刷电机的 PWM 产生主要是以连续增/减方式，带有死区控制，如下图： 

 

  通过改变 PWM 载波频率来改变 PWM 频率 
  可根据需要改变 PWM 的占空比 
  可改变 PWM 输出的极性，如高、低、强制高和强制低 
  可设置死区的大小 

通常在 PWM 的周期值时检测电流的大小。 
PWM 的产生和电机换相的具体实现见例程。 

 

3.7 死区的设置 

在逆变电路中，为了避免同一桥臂上两个功率器件的同时导通，在设计时往往需要

设置死区，通过硬件设计往往增加电路的复杂性，在这里与 SEED-DEC2812 相连，可

以通过设置 DSP 的死区控制寄存器来避免，具体值由实际情况决定，如功率器件的下

降时间和下降时间的延时等。实际中，通常将死区时间设定的比较大，如 2us。 
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第 4 章 

直流无刷电机的调速 

4.1 电机闭环调速 

理想的直流无刷电机的感应电动势和电磁转矩的公式如下： 

2
3 pE N Blrπ ω=  

4
3e p sT N Blriπ=  

式中   pN —通电导体数； 

     B —永磁体产生的气隙磁通密度； 

   l —转子铁心长度； 

   r —转子半径； 

   ω —转子的机械角速度 

   si —定子电流。 

由以上两个公式可见，感应电动势与转子转速成正比，电磁转矩与定子电流成正比，

因此，直流无刷电机与有刷直流电机一样具有很好的控制性能。 

任何电机的调速系统都以转速为给定量，并使电机的转速跟随给定值进行控制。为

使系统具有很好的调速性能，通常要构建一个闭环系统。 

一般来说，电机的闭环调速系统可以是单闭环系统（速度闭环），也可以是双闭环

系统（速度外环和电流内环）。速度调节器的作用是对给定速度与反馈速度之差按一定

规律进行运算，并通过运算结果对电机进行调速控制，最终使速度稳定下来，缺点是需

要的时间较长些。电流调节器的作用主要有两个：一个是在启动和大范围加减速时起电

流调节和限幅作用，另一个是使系统的抗电源扰动和负载扰动的能力增强。不过对于大
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多数场合来说，速度闭环就能达到很好的效果，相反双闭环往往增加系统的复杂性和参

数选择的难度，如果电流环处理不好，往往给调速带来不利。所以本系统主要是利用的

速度闭环调速。 

4.2 PID 调节 

在电机调速系统中，有不少调节方法，如 PID 调节和模糊控制等。由于 PID 调节

简单实用，在实际应用中 90%采用的这种方法；一些控制方法，如模糊控制和神经网

络控制往往是处于模拟仿真阶段，实际应用中很少。 

图 

 

 

 

 

 

4-1 PID 控制系统原理图 

如图 4-1，为 PID 控制系统原理图。r(t)是系统给定值，y(t)是系统的实际输出值，

给定值与实际输出值构成控制偏差 e(t)。 

e(t)= r(t)- y(t) 

e(t)作为 PID 调节器的输入，u(t)作为 PID 调节器的输出和被控对象的输入。 

在电机闭环控制中，一般采用 PI 调节器。所以模拟 PI 控制器的控制规律为 

0
0

1( ) ( ) ( )
t

u t Kp e t e t dt u
Ti

⎛ ⎞
= + +⎜ ⎟

⎝ ⎠
∫  

式中  Kp —比例系数 

 Ti —积分常数 

将上式离散化得到数字ＰＩ调节器的算法： 

比例

微分

积分 被控对象e(t) u(t) yt)r(t)

+

+

+

-
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0
0

*
k

k k j
j

u Kp e TKi e u
=

= + +∑  

式中 k —采样序号， k =0，1，2…； 

  ku —第 k 次采样时刻的输出值； 

  ke —第 k 次采样时刻输入的偏差值； 

  Ki —积分系数，Ki = /Kp Ti； 

  0u —开始进行 PI 控制时的原始初值。 

将上式进一步变化，得到 

 1 1( ) *k k k k ku u Kp e e TKi e− −= + − +  

式中 1ku − —第 1k − 次采样时刻的输出值； 

  1ke − —第 1k − 次采样时刻输入的偏差值； 

在有些时候将TKi 简单的称为Ki ，得到 

1 1( ) *k k k k ku u Kp e e Ki e− −= + − +  

4.3 PID 参数的意义和选择 

PID 三个参数在应用时通常起到不同的作用。 

  增大比例系数 P 将加快系统的响应，它的作用在于输出值较快，但不能很好稳定

在一个理想的数值，不良的结果是虽较能有效的克服扰动的影响，但有余差出现，

过大的比例系数会使系统有比较大的超调，并产生振荡，使稳定性变坏。 
  积分能在比例的基础上消除余差，它能对稳定后有累积误差的系统进行误差修整，

减小稳态误差。 
  微分具有超前作用，对于具有容量滞后的控制通道，引入微分参与控制，在微分项

设置得当的情况下，对于提高系统的动态性能指标，有着显著效果，它可以使系统

超调量减小，稳定性增加，动态误差减小。 
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综上所述，P—比例控制系统的响应快速性，快速作用于输出；I—积分控制系统的 
准确性，消除过去的累积误差；D—微分控制系统的稳定性，具有超前控制作用。当然， 
这三个参数的作用不是绝对的，对于一个系统，在进行调节的时候，就是在系统结构允 
许的情况下，在这三个参数之间权衡调整，达到最佳控制效果，实现稳快准的控制特点。  
 
 在系统调节时，可参考以上参数对控制过程的响应趋势，对参数实行先比例、后积 
分、再微分的整定步骤。 
 

具体做法： 
1）整定比例部分，将比例系数由小变大，并观察相应的系统响应，直至得到反应

快、超调小的响应曲线。 
 
2）如 1）不能满足要求，加入积分环节。如：先设置 Ki 比较小，并将 1）中比例

系数缩小（如缩小为原值的 0.8），然后增大 Ki ，使得在保持系统良好动态的情况

下，静差得到消除，在此过程中，可根据响应曲线的好坏反复改变比例系数和积分

时间，而得到满意的控制过程，得到整定参数。 
 

3）若使用比例积分控制消除了静差，但动态过程经反复调整仍不能满意，则可加

入微分控制。整定时，Td 先置零，在 2）的基础上增大 Td，同样相应的改变 Kp、
Ki ，逐步试凑以期获得满意的调节效果和控制参数。 

 
 以上是 PID 参数选择的一种方法，实际中应根据不同的系统进行选择。在本系统中， 
主要采用的是 PI 调节。控制器的输出量还要受一些物理量的极限限制，如电源额定电 
压、额定电流、占空比最大值和最小值等，因此对输出量还需要检验是否超出极限范围。 
 
 对于实验箱，通过 McBsp 总线上位机可以对 PID 参数进行设定，下位机将上位机 
下传的参数分别除以 1000 得到实际的 PID 参数。 
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第 5 章 

机械结构 

  本章描述 SEED-BLDC 模板的物理布局，说明各连接器的定义、

跳针的设置，以及它们在模板上的位置。 

5.1 板子外形和物理尺寸 

SEED-BLDC 采用两层板工艺，长 116.9mm×100.7mm，采用表面贴装元器件，元器

件双面安装 。 

SEED-BLDC 模板正面布局如下图所示 ： 

 

图 5-1 SEED-BLDC 模板正面布局 



 19

SEED-BLDC 模板反面布局如下图所示： 

 

图 5-2 SEED-BLDC 模板反面布局 

5.2 连接器 

SEED-BLDC 模板上有 7 个连接器，如下表所示： 

连接器 引脚数 功能 
P3 3 三相无刷电机 U、V、W 
P4 5 有位置传感器电机的霍尔传感器输出端 
P5 4 模拟部分电源的输入端 
P6 26 电机控制驱动部分接口，包括 PWM 和 AD 等 
P8 5 与控制部分 CAP 接口，无位置传感器电机反电动势输出端

P9 5 与控制部分 CAP 接口，有位置传感器的电机霍尔输出端 
P10 2 电机的直流母线电压的输入端 
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5.2.1 P3: 三相无刷电机 U、V、W 

 

图 5－3 三相无刷电机 U、V、W 的输入端 

SEED-BLDC 上有一个三孔的凤凰端子，为三相直流无刷电机 U、V、W 的输入端。

如图 5－3。 

5.2.2 P4: 有位置传感器的电机的霍尔传感器输出端 

采用 2mm 间距、5－芯单排直插式连接器，与有位置传感器的电机的霍尔传感器输出

端相连。其定义如下表： 

引脚号 信号 方向 
1 +5V 电源 输出 
2 HALL1 输入 
3 HALL2 输入 
4 HALL3 输入 
5 DGND — 

5.2.3 P5: 模拟部分电源的输入端 

SEED-BLDC 上有一个 4 针的插座，用于模拟部分电源的输入端，其定义如下表： 

引脚号 信号 方向 
1 +15V 电源 输入 
2 -15V 电源 输入 
3 GND — 
4 +5V 电源 输入 
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5.2.4 P6: 电机控制驱动部分接口 

电机控制驱动部分接口采用 2.54mm 间距、26-芯双排直插式连接器，其引脚定义如下： 

引脚号 信号 方向 
1 PWM1 输入 
2 PWM2 输入 
3 PWM3 输入 
4 PWM4 输入 
5 PWM5 输入 
6 PWM6 输入 
7 — — 
8 — — 
9 PDPINTA 输出 

10 — — 
11 LED1 输出 
12 LED2 输出 
13 LED3 输出 
14 — — 
15 — — 
16 GND — 
17 GND — 
18 GND — 
19 — — 
20 — — 
21 — — 
22 — — 
23 — — 
24 — — 
25 AD1 输出 
26 AD0 输出 
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5.2.5 P8: 无位置传感器电机反电动势输出端 

 采用 2mm 间距、5－芯单排直插式连接器，其引脚定义如下： 

引脚号 信号 方向 
1 +5V 电源 输出 
2 CAP1 输出 
3 CAP2 输出 
4 CAP3 输出 
5 DGND — 

5.2.6 P9: 与控制部分 CAP 接口，有位置传感器电机霍尔输出端 

引脚号 信号 方向 
1 +5V 电源 输出 
2 CAP4 输出 
3 CAP5 输出 
4 CAP6 输出 
5 DGND — 

5.2.7 P10: 电机的直流母线电压的输入端 

SEED-BLDC 上有一个两孔的凤凰端子，为三相直流无刷电机直流母线电压的输入

端，如图 7－4。 

 

图 5－4 直流母线电压的输入端 
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5.3 LED 指示灯 

在 SEED-BLDC 系统中共有 5 个指示灯，分别为 D12、D13、D14、D15、D16，
其具体功能如下表： 

标号 功能 
D12 过流指示，当母线电流过大时，灯点亮，否则熄灭 
D13 过压指示，当直流母线电压过大时，灯点亮，否则熄灭 
D14 程序运行显示 
D15 模拟电源＋5V 的输入显示 
D16 功率部分电源＋5V 的显示 
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第 6 章 

测试程序 

SEED-BLDC 系统的测试程序包括一下几个部分：  

  有位置传感器无刷电机的开环控制 
  有位置传感器无刷电机的闭环控制，采用 PID 控制 
  无位置传感器无刷电机的开环控制 
  若与实验箱连，与上位机相连的有位置传感器的无刷电机的闭环 PID 控制 

 
注：测试程序的工程调试环境是以合众达公司的 USB 口仿真器建立的，为了方便

起见，推荐用户使用合众达公司的 USB 口仿真器进行测试。如果使用其他类型的仿真

器，请参考附录创建相应的工程调试环境。 

6.1 有位置传感器无刷电机的开环控制 

测试过程如下： 

  将 P3 和三相无刷电机的 U、V、W 连接；将电机的霍尔传感器输出与 SEED-BLDC
的 P4 相连； 

  P10 与＋24V 的外接电源相连； 
  P5 和外接的开关电源相连或者和实验箱上的电源接口相连； 
  P6 和 DEC2812 的 J17 相连，注意正确连接，勿接反；P9 和 DEC2812 的 J18 相

连 
  上电观察 D15 和 D16 指示灯是否点亮，否则断电检查系统。 
  将 sensor-openloop 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
  打开 CCS，在 CCS 中用 Project→Open…命令，加载 sensor-openloop 目录下的

edit.pjt； 
  在 CCS 中用 File→Load GEL…命令，加载 sensor-openloop 目录下的 F2812.gel； 
  在CCS中用File→Load Program…命令，加载sensor-openloop目录下的edit.out； 
  在 CCS 中用 Debug→Go Main 命令执行到 C 的 main()函数处，如图 6-1； 
  按 F5 运行，电机变以一定的速度旋转起来，通过观察变量 Speed 的值，可以知

道此时速度的值；通过观察数组 test[]的值，可以知道过去一段时间内速度的值，

如图 6-2； 
  程序运行过程中，灯 D14 闪烁，表示程序在运行；如果灯 D13 点亮，表明有过压

现象出现；如果灯 D12 点亮，表明有过流现象出现。 
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图 6-1  

 

 
图 6-2 
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6.2 有位置传感器无刷电机的闭环控制 

测试过程如下： 

  将 P3 和三相无刷电机的 U、V、W 连接；将电机的霍尔传感器输出与 SEED-BLDC
的 P4 相连； 

  P10 与＋24V 的外接电源相连； 
  P5 和外接的开关电源相连或者和实验箱上的电源接口相连； 
  P6 和 DEC2812 的 J17 相连，注意正确连接，勿接反；P9 和 DEC2812 的 J18 相

连 
  上电观察 D15 和 D16 指示灯是否点亮，否则断电检查系统。 
  将 sensor-closeloop 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
  打开 CCS，在 CCS 中用 Project→Open…命令，加载 sensor-closeloop 目录下的

edit.pjt； 
  在 CCS 中用 File→Load GEL…命令，加载 sensor-closeloop 目录下的 F2812.gel； 
  在 CCS 中用 File→Load Program…命令，加载 sensor-closeloop 目录下的

edit.out； 
  在 CCS 中用 Debug→Go Main 命令执行到 C 的 main()函数处； 
  按图 6-3 设定断点，按 F5 运行，电机便旋转起来，通过观察变量 Speed 的值，可

以知道此时速度的值；通过观察数组 test[]的值，可以知道过去一段时间内速度的

值； 
  在 CCS 中用 View→Graph→Time/Frequency…命令，按图 6-3 进行设置，点击

OK 后即可观察到电机从启动到旋转 2000 转的过程中速度的变化曲线，如图 6-4； 
  在 weizhisudupid.c 文件中通过改变参数 kp，ki，kd 的值，重新编译下载运行后，

按上一步重新观察图形，便可以得到不同参数下速度的变化曲线； 
  程序运行过程中，灯 D14 闪烁，表示程序在运行；如果灯 D13 点亮，表明有过压

现象出现；如果灯 D12 点亮，表明有过流现象出现。 
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图 6-3 

 

 
图 6-4 
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6.3 无位置传感器无刷电机的开环控制 

SEED-BLDC 模板也支持无位置传感器无刷电机的开环控制。 

测试过程如下： 

  将 P3 和三相无刷电机的 U、V、W 连接； 
  P10 与＋24V 的外接电源相连； 
  P5 和外接的开关电源相连或者和实验箱上的电源接口相连； 
  P6 和 DEC2812 的 J17 相连，注意正确连接，勿接反；P8 和 DEC2812 的 J18 相

连 
  上电观察 D15 和 D16 指示灯是否点亮，否则断电检查系统。 
  将 sensorless 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
  打开 CCS，在 CCS 中用 Project→Open…命令，加载 sensorless 目录下的 edit.pjt； 
  在 CCS 中用 File→Load GEL…命令，加载 sensorless 目录下的 F2812.gel； 
  在 CCS 中用 File→Load Program…命令，加载 sensorless 目录下的 edit.out； 
  在 CCS 中用 Debug→Go Main 命令执行到 C 的 main()函数处； 
  按 F5 运行，电机变以一定的速度旋转起来，通过观察变量 Speed 的值，可以知

道此时速度的值；通过观察数组 test[]的值，可以知道过去一段时间内速度的值； 

6.4 有位置传感器无刷电机的实验箱的控制 

SEED-BLDC 模板也可以与实验箱相连， 

测试过程如下： 

  将 P3 和三相无刷电机的 U、V、W 连接；将电机的霍尔传感器输出与 SEED-BLDC
的 P4 相连； 

  P10 与＋24V 的外接电源相连； 
  P5 和 DEC2812 的 J12 相连； 
  P6 和 DEC2812 的 J17 相连，注意正确连接，勿接反；P9 和 DEC2812 的 J18 相

连 
  上电观察 D15 和 D16 指示灯是否点亮，否则断电检查系统。 
  将 dtk 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
  打开 CCS，在 CCS 中用 Tool→F28xx On-Chip Flash Programmer 命令，进入到

图 6-5 的界面，点击 Browse…，打开 dtk/Debug/edit.out，点击 Execute Operation，
将程序烧写到 DEC2812 的 flash 中去 
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下载完成后，关闭 CCS，系统断电，拔掉仿真器；系统重新上电，SEED-BLDC
上的 D14 便闪烁起来，否则说明存在问题，可能没有烧写成功。。如果烧写成功，

便可以进行电机的试验箱控制，如下面步骤： 
 
 

 
图 6-5 

 
1) 按试验箱液晶上的 RESET 按钮一下，将试验箱复位； 
2) 按试验箱上的键盘 ENTER 键，进入新的界面，然后按键盘上的 2 键，移动到

用户菜单，然后按键盘 ENTER 键，进入新界面； 
3) 点击 SEED-DEC2812 上 J2 ，DSP 复位，进入新界面； 
4) 按键盘上的 2 键，光标移动到“直流电机操作”，按 ENTER 键，然后按键盘 6，

光标移动到“运行”，按 ENTER 键，然后电机便旋转起来； 
5) 按键 8，光标移动到“直流电机转速”，按 ENTER 键，输入转速，如 2500，按

ENTER 键；按 2 键，光标移动到“P 参数设定”，按 ENTER 键，输入 P，如 3，
按 ENTER 键；光标移动到“I 参数设定”，按 ENTER 键，输入 I，如 20，按

ENTER 键；然后电机便以 2500 左右的转速旋转起来； 
6) 反复步骤 14），可以重新设定速度和 P I D 参数； 
7) 按键盘上的 2 键，光标移动到“直流电机操作”，按 ENTER 键，然后按键盘 6，

光标移动到“反向”，按 ENTER 键，然后电机便以相反的方向旋转起来；光标

移动到“停止”，按 ENTER 键，然后电机便停止。 
8) 如果电机运行不正常，将 DSP 和试验箱复位，然后重新按上述步骤；或者断

电后重新上电。 
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  注：此程序针对电机空载；速度通常设定在 1200~3200 左右；P I D 参数通常在

P=3， I=20， D=0 左右的时候系统比较稳定；若电机旋转速度比较快，最好不要

将旋转方向改变，可以在速度较低的时候，如 2500 等，进行换向控制。  
  由于 SEED-BLDC 不是试验箱的标准配件，因此会在复位系统后主界面上显示“通

讯自检不成功，请复位系统”。 
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附录 A 

工程调试环境的建立 

这里以 SEED-BLDC 的 weizhiopenloop 测试程序为例说明，如何建立调试工程环境的

建立。 

1． 打开 edit.pjt 工程 
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2． 装入 F2812.GEL 文件 
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3． 装入可执行的 edit.out 
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4． 运行 Debug→Go Main 命令，执行程序到 C 程序的主函数 main()。 
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5． 然后即可设置观察窗与断点等调试信息。 
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6． 保存这些设置为 edit.wks，下才直接 Load Workspace 就可见到与这次相同的调试

环境了。 
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附录 B 

连接线定义 

连接线定义： 
1．直流无刷电机的引线共有 8 条，其中： 

 3 根较粗的白蓝绿引线需延长 50cm，然后和 3 脚的凤凰端子相连，用于给电机供电。

和 SEED-BLDC 的 P3 相连。其中： 
粗白-----P3 的 U 
粗蓝-----P3 的 V 
粗绿-----P3 的 W 

 5 根较细的引线需延长 50cm，和 5 脚的端子相连，然后和 SEED-BLDC 的 P4 相连。 
5 根引线的定义为： 

细红----P4 的 1 
细白----P4 的 2 
细蓝----P4 的 3 
细绿----P4 的 4 
细黑--- P4 的 5 

2．JP26170 连接线：2 头为 IDC-26P 压线座，中间为 170cm*26 芯的扁平电缆。 
用于 SEED-BLDC 的 P6 和 SEED-DEC2812 的 J17 相连： 
P6.1----- J17.1 
…….. 
P6.26----- J17.26 

3. 5 芯的连接线，用于 SEED-BLDC 的 P9（或 P8）和 SEED-DEC2812 的 J18 相连，连

接线两头为 5 芯的端子，中间为 20cm*5 芯的扁平电缆。 
P9.1----- J18.1 
P9.2----- J18.2 
P9.3----- J18.3 
P9.4----- J18.4 
P9.5----- J18.5 

4．24V/5A 的电源和 SEED-BLDC 的 P10 相连，50cm*0.75mm。 
电源的 24V 输出----- P10 的+  
电源的地----- P10 的- 
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5．4 芯的电源连线（+5V，+15V 和-15V），用于 SEED-BLDC 的 P5 与 SEED-DEC2812
的 J12 相连， 
P5.1----- J12.1————→  +15V 
P5.2----- J12.2————→  -15V 
P5.3----- J12.3————→  GND 
P5.4----- J12.4————→  +5V 
 

 


