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o Circult Breaker

W Stimulus Requirements Lab 3

O

A/D voltage and current values:- Register Stimulus
one file two data columns inject into AD1BUFO

— AC voltage scaled A/D input :- Excel spread sheet
— AC current scaled A/D input :- Excel spread sheet

Zero Crossin?_6OHz line frequency clock :- Clock
Stimulus Inject into IC1

ésD%nch Test button:- Stimulus Controller pulse high

Asynch Reset button:- Stimulus Controller pulse
high RD2

Solenoid Trip output:- Watch window LATD [Bit 1]
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o Circult Breaker
YESIER: Zero Crossing Lab 3a

o Open MPLAB® IDE
Select menu “File>Open Workspace...
—  Select the “11015 MS2 / Lab3 / CircuitBreaker.mcw”

— OR Select menu “File>Recent
Workspaces>CircuitBreaker”

— Build the project

o Preparing stimulus
— Open the Excel spread sheet “VoltageCurrent.x|s”
— View the data and graph representations
— Copy the 2 columns of data to be used as A/D readings

— Within the MPLAB® IDE, open “File>New” and paste
them into a new file

— Save and name the file “xxxxxxxx.txt”
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o Circuit Breaker

L Zero Crossing Lab 3a

o Open Stimulus and attach A/D file

— Select “Debugger>Stimulus>New Workbook”

— Select the “Register Injection” tab at the top

— Enter an optional label if desired

— Select Register “AD1BUFO” to inject data

— Select Trigger type “Demand”

—  Width will be “2” bytes

— Add the data file name as specified in the first step
— Select “Yes” for wrap

— Select “Dec” for decimal data type

— Add optional comment
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N Circuit Breaker
VESEER: Zero Crossing Lab 3a

o Stimulus define ZC clock
— Select the “Clock Stimulus” tab at the top
— Enter an optional label if desired

— Select “IC1” from drop down under “Pin” Column for
InputCapture 1

— Select “Low” as “Initial” state from drop down

— Set “Low Cycles” to “333333". Set “High Cycles” to
“333333” 60hz clock at 40 MIPS (six 3’s in each)

— Select the “Begin” box. Leave at default “At Start”
— Select the “End” box. Leave at default “Never”
— Add optional comment
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o Circuit Breaker
s Zero Crossing Lab 3a

o Apply Synchronous Stimulus

— Select the “Apply” button at the bottom of the stimulus
window

— You are now ready to test
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IR Circuit Breaker
VESEER: Zero Crossing Lab 3a

o Testing. Execution
—  Select “Reset” and then “Run”

— Watch the variables in the watch window. Once the
“Power” value has changed, stop the program

o Testing. Verify Power

— Verilgy the Power value is equal to the Power value in
the Excel spread sheet for the injected data. (One tab in
the spread sheet for different test data)

— View the File Register window at address 0x4780. Note
the A/D data is placed here using the DMA and
ﬁerlpheral Indirect address mode. (Handled totally by

ardware within the silicon)
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Circult Breaker
Zero Crossing Lab 3b

o Verification using DMCI. Slider setup

Select “Tools>Data Monitor and Control Interface”
Click “Tiled window view” button (bottom 4t button)
Adjust the tiles so you have 4 graphs and 1slider visible
Enable the slider by setting the check box in upper left

Right click in colored area of slider to bring up the
configuration

Set the configuration up as displayed on next page
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h&@% Zero Crossing Lab 3b

o Slider configuration Soo 1|

Dynamic Data Control Properties ed

_ Dyn am | C se I ectl on ~ Slider Control Settings

— Global Symbals —Absolute Address
. ac i (" Data
o 11 d,, bI Dynamic
Load” variable = AoRen T e |
i CurrentCapture

J

- D I S p I ay fo r m a_t D e CI m a_ q DMASampleMumber Address: I

]

o Upper ||m|t 150 N "LDad.ﬁ.rraY

LewSamplePeriod _

é....prE Data Size: |15 Bite vI
— Lower limit 100 L v~ | oataRace [ ]
— Allow refresh

\ S Dizplay Format: IDecimaI "I
= H

SelecidVarmble:___ ~  petms [0

—  Apply Run-Time\t‘;j‘fm T et [

changes as prass PPN
“Halt, Write, Run - Iterachve Behavi

Ty
1
\ [ allow Refresh Update
¥ Apply Run-Time Changes IHaIt, Write, Run j

| 0K I Cancel | Help

© 2007 Microchip Technology Incorporated. All Rights Reserved. Class Slide 9



TE
dpo‘\“’ CH~°<
& %

MASTERS
(Conference

Circult Breaker
Zero Crossing Lab 3b

o Verification using DMCI. Graph Setup

Enable the 4 graphs by setting the check box in upper
left of each.

Right click in the center of the first graph
Select the top item “Configure Data Source”

Go through each tab, one for each graph and set them
up as shown on the next 4 pages
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VaSHER: Zero Crossing Lab 3b

Dynamic Data View Properties 21|

Graph 1 |Graph 2| Graph 3| Graph 4|

r Graph Control Settings

O G rap h 1 C O n f I g u r at I O n _Slt_'ezn:;gf;Tuf:::z::ﬁm Histary Buffer Length: |25-5—

_ Dyn am I C se I e Ctl on I™ simulator Realtime Update view scale: [100%

“ . ” ] ,[E"Ejﬁ"m?ﬁ"'s— ?‘bsgl::ﬁ.ddress
— “ADCReadings.ANO” variable o

+- AND

— Display format “Decimal’ e [

- DMASampleMumber
S | “3 2 , - Load Data Size: I 15 Bits 'I
- am p e C O u n t T Data Range: ILlnsigned "l

— Persist Previous Run data Srovanry )| orfomt e ]

rGelected Variable: First Index: IU
: 11 ” CRe o
— Title “Voltage T
Address:
@m T Sample Count: |32

—Diws
¥ Persist Previous Run Session Data
~ [™ Auto Assign Title

Title: I Voltage

/

/

L

X Axis Label: I ¥ Axis

¥ Axis Label: I ¥ Axis

0K I Cancel Help

© 2007 Microchip Technology Incorporated. All Rights Reserved. Class Slide 11



oo TEChng,

N Circuit Breaker
pLIILY Zero Crossing Lab 3b

Dynamic Data View Properties 2=l

Graph 1 Graph 2 |Graph 3| Graph 4|

rGraph Control Settings

O G rap h 2 C O n f I g u r at I O n _SIEET:):i::f:pTuf:::z:r:rﬁon Histary Buffer Lenath: |25-:—

_ Dyn amlC Selectl on \ I~ Simuator Realtime Update view seale: [100%
— “ADCReadings.AN1" variable Sinn—

Jd . [E-AND

— Display format “Decimal > om T

/[

/

- DMASampleMumber
S | “3 2 , - Load Data Size: I 15 Bits "I
- am p e C O u n t I .E. Data Range: ILlnsignEd e I

— Persist Previous Run data ooy ] Deybomas ol ]

o Gelected Variable: First Index: Il.’]
: 11 ” CREgmas, AN1
— Title “Current b [E——
Address:
@?CU » Sample Count: |32
r Display ings

|V Persist Previous Run Session Data

[™ Auto Assign Title

\'ﬁﬂe: I Current

X Axis Label: I X Axis

/

L

¥ Axis Label: I ¥ Axis

OK I Cancel Help
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VaSHER: Zero Crossing Lab 3b

Dynamic Data View Properties 2 xl

Graph 1| Graph 2 Graph 3 | Graph 4 |

rGraph Control Settings

r Streaming Data Configuration

1 1 ™ Data Capture Ttigger History Buffer Length: |E55
o Graph 3 configuration 5 e o
/ m

— Simulator Realtime Update/-%m e e
History Buffer “256” ;{ e [

B - DMASampleMumber

I 1 / ;ZTSamplePeriod Address: I—
— Dynamic selection O e e [
View Scale “100%” , soleno :

- Temp . -
— . TestButtonCount Display Format: IDeumaI "I

— “Solenoid” variable P et [
Last Index: |—

Address:

— Display format “Decimal” e ]

Display Settings

— Persist Previous Run data o7 st rovos uneson oo

™ Auto Assign Title
I Title: I Solencid TRIP output

— Title “Solenoid TRIP output”™— s s

¥ Axis Label: I ¥ Axis

OK I Cancel Help
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VaSHER: Zero Crossing Lab 3b

Dynamic Data View Properties 21|

Graph 1| Graph 2| Graph 3 Graph 4 |

r Graph Control Settings

O G rap h 4 C O n fl g u ratl O n _Slt_'ezn:;gf;Tuf:::z::ﬁm Histary Buffer Length: |25-5—

_ Dyn am I C se I e Ctl on I™ simulator Realtime Update view scale: [toose =
“ " . ol g"gﬁﬂf R ?bSE':E Address
— “PowerArray” variable -

- Power

— Display format “Decimal’ [ o

- PreviousCapture
- Solenoid

— Sample count “32” \ N
B - - B Dislay Format: [Deamal =]
Persist Previous Run data | = e

- (14 3] Fower
— It e Owe r Last Index: ISZ—

Address:
P“BOG T Sample Count: I 32

\\

—Dimms
¥ Persist Previous Run Session Data
o [™ Auto Assign Title

\Tﬁje: I Power

X Axis Label: I ¥ Axis

Data Size: |32 Bits i

/

¥ Axis Label: I ¥ Axis

0K I Cancel Help
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Circult Breaker
Zero Crossing Lab 3b

o Testing using the DMCI

Reset the application
Start execution
Select the slider control button with left mouse button

Adjust the slider keeping the mouse button down until
you have the desired value.

Release the mouse and the selected value will be
applied into the Load variable

When you raise the value above 116% the trip will
occur

Set an Asynch stimulus to reset the breaker after you
lower the Load percentage
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Circuit Breaker
Extended reach Lab 3b

o Verify by tracing data

Focus on Stimulus workbook

Select the “Register Trace” tab at the top

Enter an optional label if desired

Select Register “PowerTraceValue” to monitor

Trigger type “PC=" will be the default for data variables
Select the label “TracePower” for the PC value

Set width to “4” as the variable is a long (4 bytes)
Provide the file name to log the data into

Select “Dec” for decimal data type

Add optional comment
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SR Circuit Breaker
YARTER: Extended reach Lab 3b

o Apply updated Stimulus

— Select the “Apply” button at the bottom of the stimulus
window

o Testing. Execution
— Clear the “Power” value in the watch window
— Select “Reset” and then “Run”

— Waitch the variables in the watch window. Once the
“Power” value has changed, stop the program

— Select the “Remove” button at the bottom of the stimulus
window to allow the trace file to be closed
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YARTER: Extended reach Lab 3b

o Open the trace data file. “ Select All” data within the file
and “Copy”

o Open the Excel spread sheet “VoltageCurrent.xls”

o Highlight an empty cell in a free column next to the
highest cell of calculated power values, that you will
compare the data to

o “Paste” the data. This will fill the column adjacent to the
column you are going to compare the data with

o Verify at each row (one set of A/D data) that the power
traced out, matches the spread sheet calculations
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Circuit Breaker
Extended reach Lab 3b

o Additional Extra Objective

Create different A/D input files us.ingg1 the different tabs
\éwtthm the EXCEL spread sheet, and test each set of
ata.

Use “Over Current” and “Over Voltage” and check if the
“Trip” output is triggered.

The “Trip”Bpin IS RD1, shown as
“LATD [Bit 1]” in watch window

Create asynch button for “Test” (RD3) and test
Create asynch button for “Reset” (RD2) and test
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o Following are block diagrams to explain how
the application has been designed and how the
peripherals are operating within the application

— Overall block diagram

— ZC Input Capture block diagram
— Timer 3 block diagram

— ADC block diagram

— DMAC block diagram
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e Block Diagram Lab 3

Line
Trip Ta Load ;
Relay

Current,

Voltage

Divider

Zero Cross ivde
Detector

Reset

Reset Test Test

Button Button
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o Input Capture

AC Zero Crossing voltage triggers IC1 on rising edge

— Uses TMR2 as time base, free running 16-bit mode
period is 1/16 of TMR3 rate, no interrupts

— IC1 Interrupts firmware to re-calculate A/D sampling
period (TMR3 Period value)

— Maintains phase lock with AC line

o Timer 3 configuration
— Period is set to 1/32 of AC line period
— Creates 32 identically spaced samples per line cycle

— Period is adjusted by IC1 to compensate for Phase and
line frequency shifts

— Triggers ADC conversions for both voltage and current
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“zs' Input Capture Interrupt Lab 3

Inout Capture Calculate A/D Sampling
Period time from last
Zero Crossing DUt Capture

New Period
> PR3?

Increment PR3

Adjust Period
register for Timer 3

New Period

Decrement PR3 < PR3?

Return

from Interrupt
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asTER: TMR3 Interrupt Lab 3

TMR3 Period

TMR3 Interrupt
Match

Each Sample

Initiate ADC
sample & convert

Trip Breaker Over Voltage?

Trip Breaker

Return j
from Interrupt |
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ems' Hardware Configuration Lab 3

o A/D configuration
— Simultaneous sampling CHO=AN1 and CH1=ANO
— Conversion Triggered by TMR3 period match

— Uses scatter / gather offset address generation for DMAC
use, maintaining circular buffer computations

— Interrupt detected and handled by DMAC hardware

o DMAC configuration
— Services ADC conversion completion
— Computes final destination address for ADC results

— Moves data from AD1BUFO to either Current[] or
Voltagel] dual port RAM array

— Interrupts firmware when both arrays are completely full
with 32 A/D samples (64 transfers)
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~ Circult Breaker
Slrznulator ADC Lab 3

Column__1 1) TMR3 Period Match Triggers A/D conversion
2) Two columns of Register Injection are read by the
Register simulator ADC
Injection 3) Completed A/D conversion triggers DMAC
txt file 4) DMAC reads results from AD1BUFO and writes them to
' Current and Voltage arrays
2 Columns

5) One DMA transfer takes place for each conversion

6) ADC computes the offset address based on channel
number & circular buffer; this is read by the DMAC

7) No firmware is involved; this process is completely
automated by hardware

Simultaneous 9 ADC

Sample Scatter
Ch0 = AN1 Gather Trigger A2 TMR3
Chl = ANO 2 AID SR VIEE Arrays in dual
5 | ported RAM
. m 0
Trigger| | = | £ Current[] (ANO) ;2282; ]
®)
DMAC! | | 3 by user code at

Voltage[] (AN1) EEUALLE
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asTER: DMAC Interrupt Lab 3

DMACO Interrupt every Calculate
32 Samples, 1 AC Line Cycle Real Power

Trip Breaker Test Button?

Reset Breaker Reset Button?

Return

from Interrupt |
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